Authentication failed and Blooetooth 5.0

Hi there.

I am a relatively new MOD DUO X user, and I need some help with it.

My device does not want to connect to the MOD cloud (bottom right corner icon says Failed to connect to MOD cloud), neither I can download any modules or pedalboards from the website. However, available not installed modules are visible in the plugin store tab, but when I try to obtain one, it says “Cannot install plugin, authentication failed”.

My laptop runs Windows 10. (Windows users, I know, right… :smile: ) I have tried to connect using PC and other laptop both running Windows 7, but the same problem persists.

On top of that, before posting the problem, I wanted to try my luck with Bluetooth connectivity. Didn’t even manage to make MOD recognise Bluetooth v5.0 dongle. The device status was - Unsupported (- the Bluetooth version of the dongle in use is too old (needs >= Bluetooth 3 or newer version)) That dongle below:

But his could be an issue with the dongle itself…

My MOD Duo X
Machine: aarch64
Release: 4.4.167-rt176-duox
Version: #7 SMP PREEMPT Sun Jul 26 06:44:54 UTC 2020

Before you ask:
I have tried modwiki troubleshooting suggestions and most obvious solutions, but none of them worked.

The only thing that could potentially cause the problem is my Internet connection. I don’t have a home broadband cable and router, and instead, I use mobile data to access the web. USB tethering mode for the PC and mobile hotspot for laptops respectively.

Please note that I am able to access plugin store but can’t download anything because of the failed authentication.

Thanks in advance,

Any thoughts?

PM your serial number and we will take look at our logs to see what we find.

Regarding the bluetooth adapter, might just be unsupported yes.
You might be the first to try a BT5.0 adapter.