Can't manually update MOD DUO (OS X High Sierra)


#1

I can’t manually update my MOD DUO. It is on verison 0.12 I believe, as it is not automatically updating when accessing the web interface.

When following the described steps everything works until I unplug the USB. Then it says ‘eject not detect’.
I’ve tried ejecting via the finder context menut, moving to trash, disk utility in the terminal and gui and even tho it says “not mounted” the MOD itself doesn’t upgrade.

Any ideas anyone?

Thx a lot!


#2

Hi @flip,
sorry for the inconvenience. Updating from version 0.12 involves some extra steps.
Please follow the following steps:

  1. Please download the version 1.0.6 image: http://download.moddevices.com/releases/modduo/modduo-v1.0.6.tar
  2. Rename that file to modduo.tar.
  3. Do the manual update like described on https://wiki.moddevices.com/wiki/Releases#Manual_update

Please let me know if that works. Once you reached version 1.0, the update mechanism should work without renaming files. So then, you repeat step 3 to reach version 1.6. (No need to install versions 1.1 to 1.5)

In case that does not work for you, please let me know if you used SSH and the command line before, just to give me a picture of your tech-skills.
Best regards
Jakob


#3

Hi Jakob,

thx for the quick reply, I will try your steps now
and let you know if it worked for me.

Otherwise let’s fire up the terminal (:


#4

Sadly, this also didn’t work.
The same problem. As soon as I remove the USB cable the MOD display shows: ‘eject not detect’.
Even though I ejected the DUO storage device safely.


#5

@flip

If you want you can drop by our office in order to have it updated.

Your unit is from the very first batches and some of them pose some problems to update


#6

Hey Gian, good to hear from you. :slight_smile:

I’ll gladly come by, thx!


#7

Lucky to be in the neighborhood!