Continuous Xruns

Hello, I’m pretty new here but I’ve been reading this forum for a week or more now. I purchased a used Mod Duo a couple of weeks ago. I really dig the sound of the unit and all the functionality but the xrun issue is pretty much ruining it. I’ve tried to record a couple of things with this unit and the glitch of the xruns have ruined every take. I tried contacting customer support because after reading and re-reading all the issues with Xruns in this forum I never did come across any post with an explanation or fix. Someone from customer service got back to me and told me the issue was resolved. I am running the latest OS on the Unit. Last night I left it disconnected from the USB and when I woke up and checked it, there were 80 Xruns in the time I was asleep last night and it wasn’t connected to anything and not being used other than being powered on.

I really hope someone here knows about a fix to this issue. I’m not sure how this unit could be usable for anyone that was experiencing this issue.

Thanks in advance for any helpful tips or suggestions you may have. For the record I am not really a linux user and do not have a Linux desktop. Any trouble shooting will have to be done with my Mac book pro.

1 Like

I guess I’ll leave this post here to help anyone else that might be new to this unit and may run into the same issue. When I purchased my Duo and first connected it to my computer it did an auto update to the latest OS. After disusing the issue I was having with constant xruns with Salvador Orona at MOD he suggest doing a manual Install of the latest OS.

Happy to say after running the manual install of the latest OS the unit has not has a single xrun in over an hour. In the settings page of the editor app, the unit reports having the exact same version of the OS as it previously did but now it seems to be totally solid. Really happy cause I’m otherwise loving this processor. Thanks so much for the help getting it sorted out Salvador!


Unfortunately, I’m back here again. The problem definitely seems to be reduced but sadly I am still getting Xruns. Now it seems to happen every couple of hours instead of every 15 minutes but still happening. The board I have been experimenting/troubleshooting with today only runs just over 40% cpu power. Salvador thought maybe it was that I had it connected through a usb hub or that my hub was causing a usb bandwidth issue, but I connected it directly to the laptop and I am still getting Xruns. Now I have the Duo connected to another computer entirely and there is nothing else connected to that machine. Had it hooked up to that machine for about an hour and it already happened once. Not sure what else to try? Anyone have any thoughts or seeing similar issues with the current OS? I want to this figured out but I’d really rather be playing than trouble shooting gear.

Do you hear these xruns, or do they just appear in the xrun count?
If you can hear them, do they still happen when the unit is not connected to the PC? (over USB)

Yes and yes. I can absolutely hear it happen. If I didn’t hear it, I wouldn’t really care. The sound, when it happens is very distracting. Yes I left the Duo completely disconnected from the USB all last night while I was asleep. When I woke up and connected the USB to check it listed 104 Xruns. I had cleared the counter before disconnecting last night before bed.

hey @rickbaudio… have you seen this thread?
…and does the occurance of xruns correspond to jumps in CPU usage? a number of us have noticed both of those things happening together, and there doesn’t seem to be a logical explanation. it seems to happen less when the pedalboard is simpler, but i don’t think i’ve ever gotten it to completely disappear.


Yes! I have seen this thread. And yes, that is what is happening. I guess I was lead to believe by my communication with Salvador at MOD quality assurance that the issue had been resolved and that my situation was somehow unique. So, everyone else just ignores the glitches? Thanks for your reply! I was wondering if it was still happening to other folks. Sounds like it is. If that is the case and judging from the forum it’s been going on for some time. I wish I had read this forum more previous to purchasing.

This seems like a design issue with lack of memory and cpu power. I asked a question a while ago about memory upgrades, e.g. adding chip slots, and never got an answer. I believe this may be the achilles heel in the design. Works fine until you get to 75% CPU, which implies tapping out memory also. I hope it’s not a show stopper for them.

1 Like

Honestly, if it worked totally fine until 75% I would be fine with that. But unfortunately that has not been my experience at all. I have a board that runs just over 40% and it seems to spike to 100% and cause a glitch sound and xruns once an hour or more. I feel a bit duped by this process actually and specifically being told that this was a resolved issue. It’s pretty obviously not a resolved issue and regardless of what it is for them I’m pretty sure it’s a show stopper for me.

At this point,(and its only been a week or two) the sound of the glitch is distracting enough that I have pretty much given up on this thing. I see an HX stomp in my future way sooner than it seems this issue will be resolved.

The audio runs as high-priority, over anything else, so xruns while CPU load is under 80% is a bug, this is surely not expected.

Getting more information now would be very useful to help understanding the issue more.
Can you PM me your unit serial number? Just so I know what model it is.

The info on the forums is not always correct.
There were a couple of releases where the Duo did indeed had this behaviour of xruns, due to internal changes when planning for the Duo X that badly affected the Duo but went unnoticed for some time.
(It applies to the v1.7.x releases, and was finally fixed in v1.8.0-RC5)

Would you be okay with a full unit reset, if it meant fixing this issue?
We have been working on something new/updated for the Duo, still experimental at this point, but might very well fix this.


It might not be expected but from reading the forum it seems to be a very typical experience. Thanks for confirming that it is a bug and should not be taking place regardless of how typical an experience it seems to be for folks.

1 Like

i need to do more checking about my cpu loads when this happens, but i do believe it’s still an ongoing problem for me as well. i’m happy to help with debugging… how shall we proceed?

btw… this is only on the Duo. my experience with the DuoX has been fine.

1 Like

We are actually working on something behind the scenes that might very well fix this behaviour.
It is in line with what MOD needs, some might say mainline :wink:


woah… going to the mainline kernel? maybe? if that’s it, it’s big news… we’ve been hoping for this for years!


I’m happy to help test both test a new image and/or do some live debugging.

I’m comfortable in the terminal if there’s anything I can help run or monitor for data collection.


We will make a public announcement when testing is needed, in a form of an usual RC.
Once you see it, you will know :slight_smile:
Thanks in advance for any testing done


What operating system are you using? A quick search should turn up a wealth of options (for example “use SSH on [[your operating system]]”. )

1 Like

Thanks for the reply! Unfortunately I have no experience with SSH, so wasn’t really sure where to start. I have a macbook pro running MAC OS 10.13.6 Something I want to do with Terminal?

Any recommendations for an app to use on a Macbook pro running 10.13.6. Any info about how to run this code?

rm /root/data/last.json 
systemctl restart mod-ui

Not looking to learn to program. Hoping to do as little troubleshooting as possible. Hoping to get back to playing as soon as possible. Thanks in advance for any other guidance some of you may have.

Mac OS X includes a command-line SSH client as part of the operating system. To use it, goto Finder, and selext Go -> Utilities from the top menu. Then look for Terminal. Terminal can be used to get a local terminal window, and also supports SSH connections to remote servers.

Using the Terminal application, you can type or paste ssh root@modduo.local or ssh root@ as a fallback. The password is mod (reference) This assumes the device is connected via USB and responding to SSH - meaning it has booted up far enough for some basic services to be running even if the screen appears frozen. If the device is in a state where the main operating system hasn’t loaded, you will see a message about not being able to connect in Terminal.

1 Like