"couldn't reset pedal board"

Before I go through a detailed ‘what’s going on with my set-up’ explanation (which I haven’t got time to do right now, and I REALLY should’ve brought this up earlier :wink: ) I’m wondering what ‘Couldn’t Reset Pedalboard’ means as a message when switching between boards with the interface connected. I’ve had a few issues with boards not letting audio though when switching between them, but when the interface is connected it just hangs and this is the little dialogue thing…

Is there an easy interpretation of it, or do I have to troubleshoot all the pedals on my board to work out which one is causing this? Is it just a thing that happens if your board is WAY too processor hungry? :slight_smile:

that means an error happened in the webserver side of things when cleaning up resources of the pedalboard.
could be for many reasons, so knowing what setup or which pedalboard in specific causes this is very helpful.
when something like this happens, the pedalboard does not reset correctly and the process is cut in the middle, so other issues might arise.
it is not related to the amount of cpu used. but more complex setups make it more likely to happen, for obvious reasons.

which version are you using? this is on a duo, correct?

I’m on the latest version 1.7* on a Duo, yes.

I was using the latest board I uploaded - https://pedalboards.moddevices.com//pedalboards/5d2b96f12564d46d1c8e83c1 - but I’ve deleted the ToneStack this evening to see if that was part of the problem (just going by a process of elimination, started with that, things seemed to improve!)

When I went back to using it without the web interface, and with the newly saved version without the ToneStack, it was working fine switching between boards - no boards getting stuck with no audio (when that happens, the only fix I’ve found is to unplug the Duo and plug it back in… not great mid gig :wink: ) - it’s the risk I take using so many Beta plugins I guess, but they sound SO GOOD! (I’m now going to have to work out how to get the sound back that I had with the ToneStack… I’ve got a few ideas :slight_smile: )

Anyway, thanks for looking into it!


i have used some calf (beta) plugs also, and to me they appeared stable on my modx
…but of course missing ui etc…

the calf plugs are really great!


Update - it’s not working fine… Had it lock up on tonight’s gig numerous times - almost every time I changed boards… I’m going to have to find a fix for this ASAP!

Might be something with v1.7, try downgrading.
I will try some of your shared pedalboards to see if I can reproduce the issue with any of them


weirdly I can’t seem to be able to downgrade - tried twice to downgrade to 1.6.3, both times it just booted up again as 1.7.3… any ideas?

Make sure to boot it with left knob and footswitch pressed down before turning the power on.
Downgrades are not allowed by design, only this way.


OK, I tried this and the same thing happened… still on 1.7.3 - I’m not sure what I’m doing wrong. Is there a step-by-step guide for downgrading?

I can see the issue of the pedalboard, the snapshots (used to be called pedalboard presets) mention shiroverb2 which has been removed.
Usually the unit would handle this well, but not on this case for some reason.
We are preparing a new release right now, so I will add this in there. Plus do a backport for a stable release later on.
(I noticed something in that pedalboard is causing the audio host to crash on start, hard to say what exactly, likely a “bad” plugin)

Regarding downgrade, I will check it now…


weirdly, I’ve been trouble-shooting it this morning, and have apparently fixed it by getting rid of the Calf Gate… I moved a few things around, so it may be something else too (or the interaction between then) but having removed the 3band EQ at the start (replaced with the x42 parametric) and the Gate, and having swapped the BoobTube for TimRay.

Anyway, as of now, I can seemingly switch between boards without getting any failure :slight_smile:

Regarding Shiroverb 2 - is it going to disappear from my boards, even though I bought it? What’s the status of that? I LOVE that plugin and use it a lot…

no, nothing is removed, dont worry :slight_smile:

somehow the pedalboard was saved without taking into account that the snapshots had references to a plugin that got removed from it. some combination of adding and removing plugins triggered… :thinking:
anyway, I added another check when loading snapshots, so this particular issue wont appear again


There seems to be an issue with the firmware not allowing to enter restore mode, at least in my older Duo unit.
By pressing down the left knob and footswitch (for around 5 seconds) while you power on the unit, are you able to enter restore mode? (the mode where the leds are blue and the unit asks you to connect to the PC to copy a file)