Dwarf freeze

Description


Buttons not responding. In/Out LEDs are working.

How to reproduce


I was editing a pedalboard from web gui, then I closed the firefox tab and moved to dwarf display. I was in pedalboard display then I pressed B + C for snapshots display. Then I pressed A to move to pedalboards display and then backlight turned off and all buttons/knobs stopped working. I can hear audio correctly.

EDIT:

  1. turn on Dwarf
  2. connect via SSH (Putty)
  3. issue these commands
systemctl stop mod-ui
hmi-reset
MOD_LOG=1 mod-ui.run
  1. wait for restart
  2. once restarted, close Putty
  3. press switch C
  4. now Dwarf shouldn’t respond to any commands (switch, button, knob)

Additional information


Open the controller menu (hold left knob down), navigate to Info > Versions and write down here the version.

  • release: V1.10.1.2234

Also provide some information about your system if possible.

  • Operating system: Windows
  • System version: Windows 10, Firefox 89.0.2 (64-bit), Putty 0.74

Before I reboot, can I launch some diagnostics or get some log files via SSH?

unfortunately no.
you can run things manually to get logs in the console, but at the moment we do not store any logs whatsoever. this comes from the Duo days where CPU usage is very precious, now reconsidering the usefulness of such logs again, Dwarf being quad-core should be able to handle it…

if you want to run things manually, here are the steps:

systemctl stop mod-ui
hmi-reset
MOD_LOG=1 mod-ui.run
1 Like

Thanks. How can I set log level at startup?

you can’t. our systemd is patched to not have any logs whatsoever, again for performance reasons.

will investigate enabling them for duox/dwarf, those having more than 2 cores shouldn’t make much differences in terms of CPU.

3 Likes

It happened again few times. Not able to catch the root cause since it seems happening at random action. Probably more often while switching a pedalboard (via WEB GUI). My SSH session was open before last freeze but it doesn’t give any evidences. This is last info I can see, it’s not even pinging anymore. However SSH session is still alive.

INFO:tornado.access:200 GET /ping?_=1626428146843 (192.168.51.142) 41.60ms
DEBUG:root:[hmi] scheduling -> pi
DEBUG:root:[hmi] sending -> pi
DEBUG:root:[hmi] received <- b'r 0\x00'
DEBUG:root:[hmi] popped from queue: pi
DEBUG:root:[hmi] calling callback for pi
DEBUG:root:[hmi] queue is empty, nothing to do
INFO:tornado.access:200 GET /ping?_=1626428146844 (192.168.51.142) 30.43ms
INFO:tornado.access:200 GET /pedalboard/image/check?bundlepath=/root/.pedalboards/COMPLETE.pedalboard&v=44&_=1626428146845 (192.168.51.142) 10.13ms
INFO:tornado.access:200 GET /pedalboard/image/thumbnail.png?bundlepath=/root/.pedalboards/COMPLETE.pedalboard&tstamp=15521.5&v=44 (192.168.51.142) 19.47ms

What is the firmware version are you running? The not yet released?

Version V1.10.1.2234

Happened again. Web GUI says Disconnect - Reconnect (after few minutes with no interaction, 5-10 minutes). Tried to reconnect but it doesn’t respond, then I pushed switch C (led was turned off) and LED turned on but it doesn’t accept any command (switch, knob, button). I was connected with 2 separate SSH sessions via Putty. I suspect Dwarf freezed after I’ve closed Putty.

PuTTY

Release 0.74

Build platform: 64-bit x86 Windows
Compiler: clang 11.0.0 (https://github.com/llvm/llvm-project/ bc15bf66dcca76cc06fe71fca35b74dc4d521021), emulating Visual Studio 2013 (12.0), _MSC_VER=1800
Embedded HTML Help file: no
Source commit: 014d4fb151369f255b3debed7d15a154fd9036f5

It freeze again in a different way. Was using my pedalboard with several snapshots (no Web GUI connected, wanted to test Dwarf navigation in standalone mode). I was in snapshots menu with snapshot #7 selected. Started to play guitar for 15min then back to the Dwarf, willing to change snapshot via switch B (going up from #7 Lead to #6 Rhythm then) but it wasn’t in snapshot menu (like I left before start playing). It was in main view (switch, buttons, menu). Then I pressed switch B + C to move to snapshots view and it moved there correctly. Then I tried to change snapshot to #6 but selection wasn’t responding (pressed several times but nothing changed). Then I pressed again switch B + C and successfully moved to main view (switch, buttons, menu) but, again, I tried to change snapshot to #6 and selection wasn’t responding. So I pressed switch A and it freeze (with display’s backlight turned off). This time I didn’t start the debug info with

systemctl stop mod-ui
hmi-reset
MOD_LOG=1 mod-ui.run

so this time it seems not related to SSH and manual commands issued.

That’s obvious: if I run mod-ui.run without nohup it will close running process on Putty close.

Ok so this issue you found the reason.
Any more inputs on the other?

Seems related to editing pedalboards via WEB GUI and than using the switches on the Dwarf. Didn’t find a way to replicate it yet. I suspect it is strictly related to a specific pedalboard I’ve built. Just speculating.

That may be the case.
If you happen to learn more about it, please share as much as possible (things like what plugins are you using, etc.) for us to try to replicate it.

1 Like