GxSD2Lead issue


#1

Description


In using the GxSD2Lead on a pedalboard I noted there is an audible sound dropout when switching the effect off and that the overall gain level of the pedalboard is diminished noticeably after using it even if it is switched off again. If I reload the pedalboard on the MOD then the volume level is restored until I use the GxSD2Lead again. Other overdrive effects like the GxTubeScreamer don’t exhibit the same dropout when switched on and off. I really like the subtle Overdrive of the GxSD2Lead, it is probably one of the best simulations out there but the Pedal is unusable in it’s current state.

How to reproduce


  1. Add GxSDLead2 to a fresh new pedalboard.
  2. Engage and disengage the plugin while playing, to hear dropout.
  3. Pay attention to overall gain before and after using the plugin.

Expected/suggested solution


I’d expect it to behave like the other Overdrive plugins with no audible dropout or reduction in volume after using it.

Additional information


Open the controller menu (hold left knob down), navigate to Info > Versions and write down here the versions.

  • release: Latest 1.4 release
  • controller:

Also provide some information about your system if possible.

  • Operating system: (Linux)
  • System version: (AV Linux 2017/Debian Stretch)

#2

There seems to be a issue with the bypass implementation in the MOD UI.
GxSD2Lead has it own bypass algorithm (ramp), but it seems that it is mixed up with the MOD hard bypass somehow, so that both bypasses didn’t work properly, but interference each other.
I’ll work on it as soon I’ve some time.


#3

Hi @brummer

I appreciate you looking into it, whenever you have time is fine. I know open-source projects are a lot to juggle with ‘real’ life. :wink:

I’m actually using it with an Acoustic guitar pedalboard and it gives a nice little bit of bite for solos without getting too ‘electric’ sounding.

Thanks for all your great work on the MOD!


#4

Yes, I’m running out of time this day’s, so I’ve one question beforehand. Have you used Gx2Lead the linux version and do you experience the same issue with that?
Or is it strictly related to the MOD implementation?


#5

@brummer

I am also busy at the moment with work and have not been in the studio to try the GxSD2Lead as a plugin in a DAW, I will try and do that ASAP and reply here.