How do I update an old Duo?


#1

Description


I have a really old Mod Duo (From the original Kickstarter)
And I want to update it.

I tried the following


  1. Plug the USB into a Mac or Windows machine, no storage is seen by either system.
  2. Plugged a FAT32 usb drive into the Mod Duo and held down the left foot witch and button, no upgrade. Learned this from here: Unable to update the system
  3. Tried using this tar file: http://download.moddevices.com/releases/modduo/v1.0.0/modduo.tar

Expected/suggested solution


A firmware update

Additional information


Open the controller menu (hold left knob down), navigate to Info > Versions and write down here the versions.

  • release: It does not say in Info
  • controller: It does not say in Info

Also provide some information about your system if possible.

  • Operating system: All 3
  • System version: Mod Duo Kickstarter Edition

#2

Did you select the option System Upgrade after plug the USB?
The mass storage unit only show up after doing this.

That should be the correct file in your case.


#3

Did you select the option System Upgrade after plug the USB?

Yes I did, “Select Yes and hold down foot switch and press button”, then something about upgrading, sadly, no storage seen.

I do remember Mod saying that mine maybe was an early beta machine if that helps any…


#4

What OS you are using?

Looking at this page: https://wiki.moddevices.com/wiki/Releases can you remember (according the date perhaps) which versions do you have?


#5

It was shipped to me around the end of 2015 so I assume I am running the initial release.

It’s an original Kickstarter edition mod duo.

It does not actually say under system info. Here is a video of me checking the version: https://youtu.be/tSCB4StDStw


#6

This resolved my issue! Thanks for the offline help Ricardo!

Factory reset: https://wiki.moddevices.com/wiki/Troubleshooting_Reinstall#Factory_Reset1

Performed a factory reset from Mac OS X!

Bootfix finished, rebooted, LEDs went Blue, then Red, then Green, after 10 minutes she was reset!

Rebooted and it was on a totally different version and the Web UI wants to update to version 1.5!

AWESOME!!!