MIDI connection issues

I’m trying to use a Roland FC-300 foot controller with the MOD Duo.

When connecting it directly via MIDI, it seems some foot pedal MIDI controller events are lost. E.g. if I move a pedal up and down quickly, the knob I assigned the pedal to will just jump to a few values, and be stuck at e.g. 20% or 80% without fully reaching 0% and 100%. I have to move the pedal very slowly in order to reach the full range.

If I connect the same device via a USB MIDI adapter, it works smoothly. No events seem to be lost.

Is there anything I need to do to reconfigure the MIDI connection, to prevent this issue?

Following up on this – I’ve now played several concerts and rehearsals with USB MIDI, with no issues. Seems using plain MIDI is just not possible for now with that device.

I too am having issues with an old ADA midi pedal (0-10/±). It is not learning.

Hi, I’m having the exact same issue with the FC-300 controller and Mod Duo.

I reckon it is also the same mentioned on fractalaudio forums (search google for : jumpy midi FC-300 fractalaudio to get to the thread) and they managed to fix this. Looks like there was something wrong with “MIDI running status” implementation.

Many thanks @crenz for having found a workaround :slight_smile:

1 Like

I also own a FC-300 and stumbled across the same issue.

Expression pedal values are somehow jumpy /stuttering when the pedal is directly connected to the HW MIDI in of the Mod Duo.
Also button presses on the FC-300 can get lost.

I can verify that @crenz workaround via USB MIDI is working.
It also worked perfectly when I routed the FC-300 MIDI to my PC through MIDI OX programm (for debugging) and from PC to the Mod Duo.

I suppose that this two sorts of “conversion”

  • either remove the “MIDI running status” optimisation from the original data stream before delivered towards the Mod Duo.
  • or change the message microtiming in a way that the Mod Duo gets along with it.

Unfortunately I didn’t find a tool to provide a raw data log for the devs.

For me it seems to be a timing / timeout issue.
If the exp pedal is moved slowly the issue doesn’t appear.
The faster the pedal is moved the stronger the issue becomes.

Finally two references according to the findings of @fenixfunkfive:

I hope the great developers from moddevices can provide a fix as well. Would be really great!!

Have you been installing all the updates?
The running status (on the DIN MIDI port) was indeed an issue, but fixed since 1.8.4 I believe.

I’m running version V1.8.5 now.
If there’s a tool that can record the raw MIDI data I could make a dump for you. I guess that’ll help best.
But I didn’t find a “Wireshark” for MIDI yet :frowning:

Last time I tried to look for one, also did not find it.
There were a few, but they all normalized the MIDI messages, which is exactly not what we want (we need the raw bytes)