MIDI responding randomly after update to 1.4


#1

Description


I’ve just upgraded to 1.40, and MIDI has gone really strange - it ignores almost every press of a pedal, and movement of a CC controller, receiving data completely randomly (I’ve tried a number of ways to establish some kind of consistent bug, but it’s seemingly random)

I’ve rebooted it a couple of times, and nothing has changed it… the sound seems to be OK, and everything else about it is OK. I’m going to try reassigning a pedal and see what happens… [edit : just did this and it’s still random. took about 6 pedal presses to recognise the midi data]

How to reproduce


  1. upgrade to 1.40
  2. leave Softstep 2 connected as before (which was working this morning, and is still working for the other things it is connected to) and try to change patches.
  3. Scratch your head in wonder as the buttons work about once every 10-40 presses with no consistency.
  4. the same whether connected to my laptop or not.

Expected/suggested solution


to go back to how it was before - with my pedal board sending MIDI data and the effects responding as they’ve been programmed to.

Additional information


KMI Softstep 2 with Roland EV5 attached, via the MIDI breakout box, into the MIDI in on the MOD Duo.

Also provide some information about your system if possible.

  • Operating system: Windows
  • System version: Windows 10

#2

More info - I just connected the Softstep via USB and it’s working almost perfectly. There’s one button that it is now not responding to at all (???) but other than that, it seems to be working. There does seem to be a pronounced audible click when turning pedals on and off, but I’ll do more checking to see if that’s as it was before or a new thing…


#3

just left it unplugged for a minute before reconnecting, no change. The one button that wasn’t responding when connected via USB is obviously still sending MIDI data as it just changed the patch on one of the random number of presses I just gave it :wink:

I’m in the middle of recording at the moment, so a fix or some suggestions would be hugely appreciated when possible. I can’t do anything right now. :frowning:


#4

I say try to reinstall 1.4.0 and see if the problem is still there.
(see http://wiki.moddevices.com/wiki/Troubleshooting_Reinstall#MOD_does_not_boot.2C_or_boots_into_recovery_mode_automatically for instructions on how to force an installation. without the forced-install trigger, if the mod detects the version is the same it skips reinstall)

If it still doesn’t work, go temporarily to 1.3.2 back again.
Let me know how it goes.
I’ll try to reproduce the issue on my side.


#5

I just tried the reinstall and it was the same, so am rolling back to the previous version.

Thanks :slight_smile:


#6

…after the rollback it works just fine! #Phew :slight_smile:


#7

Hi @ll,

I have some time tomorrow late afternoon and will upgrade to 1.4.0, too. Will try to use MIDI via keyboard and controllers.

Regards, Holger


#8

Hi @solobasssteve @falkTX

I can confirm: I also have MIDI problems (have installed a test release (1.5.0)). I am using the hardware (DIN) MIDI Input and as master keyboard my Kawai-MP5 stage piano. I tried several generators (Dexed, MDA ePiano, MDA piano, …)

Regards, Holger


#9

Can you describe exactly what the issues are?
I’m going to have a look at it very soon.


#10

Hi @falkTX,

there are massiv drops of midi events: I made a video for demonstration: Mod-Duo MIDI problem

This is my setup:


Very simple: only Dexed and MDA-ePiano with a tiny-gain before output.

Regards, Holger


#11

@Codeman can you please stop the controlchaind service and check if the problem is still happening when it’s off?


#12

Hi @ricardocrudo

I have stopped controlchaind with systemctl stop controlchaind - but nothing changed. Anything else what I can try?

Regards, Holger


#13

Sadly I cannot reproduce this issue.
I created a complex-enough setup to see if midi events were being dropped.

You can see from the screenshot, only the serial-midi port is being used.
Tested in both 1.4 and 1.5/testing.

So my guess would be that some devices are sending data that breaks ttymidi (its midi data parsing is very barebones).

@Codeman Can you capture some events your device sends? The output of jack_midi_dump should be enough.
Run that on a terminal. if you’re using the MOD, use this command to start listening for messages: jack_connect ttymidi:MIDI_in midi-monitor:input


#14

Hi @falkTX

Today I have more time than the last days. I will dive in deeper and make some of your suggested tests at evening. I also will try other MIDI devices != my Kawai ( I have some Korg and Yamaha devices).

Regards, Holger


#15

Ok, I think I know what’s going on - MIDI running status.
In order to try to make ttymidi better handle (read: ignore) sysex messages, the support for midi running status got broken.

Please try this build: http://download.moddevices.com/releases/testing/modduo-v1.4.0.458.tar
I’m confident MIDI will work just like v1.3.


#16

Thank you! Will hopefully have time to install it later tonight.


#17

Hi @falkTX,

tested 1.5.461: DIN-MIDI works again! Thanks!!!

Regards, Holger