MOD DUO not connecting to web (browser) interface (Windows 10 64bit)


#21

Please post as much info as possible about that android ‘remote NDIS’ device here.

But basically we need to make MOD use the same driver.


#22

Here are some screen shots…
maybe it´s better you Tell me which kind of info do you need.


#23

@acunha Following the suggestion of @falkTX I´ve found that my system has the RNDIS driver installed but it´s using another driver for the MOD DUO.

I´ve been searching the web to find a way to make windows 10 use the correct driver for the MOD DUO without success.
I´m out of ideas…


#24

Have you tried uninstalling the current driver and letting W10 picking a new one?
Also you can try a different USB cable and different USB port. Adding a USB hub might be a good idea to try too.

Have you tried updating your computer drivers/firmwares?


#25

Yes!
I uninstalled the driver but W10 always pick the wrong one.
I tried different USB ports as well but did not tried USB HUB approach. (will try that tomorrow).

Updating the computer drivers and firmware must be the very last resource because my system is running really well.
As I mentioned the correct driver seems to be already installed and I just need to figure out how to make the W10 use it for the MOD DUO.


#26

Hello @acunha.
I´ve just tried connecting through a USB HUB and that does not work also.

When I connect the MOD DUO my W10 thinks that the device is a printer (serial) instead of a network device.
I think that we will be closer to the solution if we could understand why W10 behave like that.
Unfortunately that is far beyond my knowledge.


#27

@rogeriocouto unfortunately we’re running out of options. The remaining ones are:

  1. upgrade all firmwares/drivers from the manufacturer of your computer
  2. reset your W10 to the factory image

Considering your MOD worked on other computer, it’s not a problem with the device itself.


#28

@acunha and @falkTX

I´ve connected my android phone with usb tethering enabled and tried to update the RNDIS driver but I have the latest driver installed.

Regarding the drivers from the manufacturer of my computer I will verify at their support site if something needs to be updated.

About the system reset… that is not possible because I no longer have the factory image in my computer. The factory image had a corrupt system install and I got rid of it long time ago.
My system has a W7 clean install that was immediately updated to W10 about one year and a half ago and I´m running it with no issues since then.

I´ll keep investigating…
In the mean time I´m updating the MOD with W7 starter edition of my wife´s netbook, :unamused: and planning my pedalboards using a VM with W7 pro. :sunglasses:

In case you have any new idea please let me know.

Thanks!


#29

So just running a W7 VM inside the W10 box works? It gets recognized as a network device with the correct driver? Or are you running the W7 VM in a different computer/OS?


#30

Yes the W7 VM is running inside the same computer/OS.
Right now I´m running it on a Linux VM inside the same computer/OS.

On the W7 VM I needed to install the driver following the wiki troubleshooting but on the linux VM was a “plug and play” experience. :smiley:


#31

an update on this topic…

I just got my USB Bluetooth dongle and installed the MOD Release 1.1.0 and now I can connect the MOD DUO with my Windows 10 64bit.
Unfortunately I did not have the time to look into a solution to solve the connection problem using the USB cable.


#32

Excellent @rogeriocouto that’s good news. Now you can enjoy it without any cable hassle!


#33

Microsoft said that they are aware of the problems of the RNDIS USB network adapter in Windows 10, they are hoping to solve the problem. Once I get the answer to this problem, I will update you. Go2top, HP Support provide good driver for frim wire.