MOD Footswtich #3 not working


#1

Description


Trying the footswitch for the 1st time, although I can assign the channel 3 (like the 3 others) to a button and it displays the label correctly, when I clik on it it does not work

How to reproduce


  1. Set-up the footswitch
  2. Assign a function to channel 3 of the footswitch
  3. label is displayed correctly but clicking on it does not toggle the function
  4. I of course validated that the function worked with other channels…

Expected/suggested solution


I’m tempted to open the footswitch to see what is wrong (I assume a cable is unplugged)

Additional information


Open the controller menu (hold left knob down), navigate to Info > Versions and write down here the versions.

  • release: RC 2 1.4
  • controller: the included with RC 2 1.4

Also provide some information about your system if possible.

  • Operating system: (Linux, Mac or Windows): Windows 10 (not relevant though I think)
  • System version: (Windows 10 or Mac 10.10, etc)

#2

Hello @leDamien

If you’re willing to open it and check if the cable is connected would save a lot of time. Otherwise we can do the recall and check your unit. Please let me know what you prefer.


#3

Hi, @ricardocrudo,

so I opened it. Let’s say there is 3 parts:

  • the button itself (without its wiring): it works fine, when I push it, my ohmeter shows the toggling
  • the wiring from the button to the green PCB: not good (when I click on button #3 I see no toggling on my Ohmeter at the end of the wire: the little black connector that plug on the PCB). (you can see from the picture it had an issue, but even putting it back fully, does not solve it. I went further to remove the black connector, and still not toggling)
  • the PCB connection: it works fine, I plugged the #4 buttons on the #3 button spot and it works fine

So I’m pretty sure the trouble is that wire. Maybe the best solution would be to send me a wired button with its connector.
From what I see I’ll just need to remove 4 screws to remove the PCB, and white connector wires (hope they are not troublesome to put back) then remove the button, replace it with the new one, and plug everything back.
I’m not too confident in re-wiring the button myself (do not really have the skills or the parts), I’d prefer to have a full button so that it last for long !

What do you think ?
thanks in advance


#4

Hello @leDamien

Thanks for debugging it! You’re right, the cable must be the problem. And you’re also right about the steps to replace it. I’ll make sure you receive a wired button to replace the defective one. Please let me know if need any further help on this.

Thank you for the feedback, I’ll communicate the issue to the factory and ask them to improve the quality assurance procedure.


#6

Hi @ricardocrudo

Just to say I received the replacement wired button, and replaced it today, it works fine !!!

thanks a lot,
Damien


#7