Mod-plugin-builder validation

Hello,

I am trying to get started with mod-plugin-builder to make an auto-gain staging plugin and learn the platform dev a little (I am a C++ dev for my day job). It is always the build/test infrastructure that causes difficulties and rarely the code :stuck_out_tongue:

So thanks for creating these scripts to make the setup simpler.

I thought I would start by just using the vanilla “eg-amp-lv2-labs” plugin to start with, build, validate, deploy and test it, then duplicate it and start from that as the basis of my plugin.

Following the instructions from: https://github.com/moddevices/mod-plugin-builder I can build the plugin (I haven’t tried deploying and using it yet) but I did try using the lv2 validation like:

./validate x86_64 eg-amp-lv2-labs
Checking eg-amp.lv2…
error: Inverse functional property with several subjects:
https://falktx.com
FOAF Vocabulary Specification
mailto:falktx@falktx.com
error: Inverse functional property with several subjects:
https://falktx.com/
FOAF Vocabulary Specification
mailto:falktx@falktx.com
Found 2 errors among 107 files (checked 0 restrictions)

Any idea what this means I couldn’t find any relevant docs?

I assume there are problems with the ttl files in the example plugin but the error description doesn’t really help someone with little experience in lv2 plugin development (me) understand the issue.

If not I assume to understand these errors better I am going to need to look at the source for the lv2_validate tool but thought I would ask here first in case it helps others trying to start as well.

Thanks.

2 Likes

That specific warning happens when having some old stuff installed. I thought I had that corrected by now…
When was the last time you re-run the bootstrap?

1 Like

I ran it all today (though the clone of the mod-plugin-builder was from a few weeks or a month ago I just realized I forgot to rebase today). I will do a fresh clone and cleanup and start again and see if I still have the same issues and get back.

2 Likes

ok, please let me know if it still happens.
In theory this was fixed in Update modspectre and kxstudio-lv2-extensions · moddevices/mod-plugin-builder@f849e8c · GitHub but maybe I missed something

3 Likes

I still have the same issue. I did a full clean rebuild. Just for reference in case there is something wrong in my procedure. I did the following:

cd $HOME
export WORKDIR=$HOME/moddwarf/work
mkdir moddwarf
cd moddwarf
git clone https://github.com/moddevices/mod-plugin-builder.git
cd mod-plugin-builder
git submodule init
git submodule update
./bootstrap.sh x86_64
./bootstrap.sh moddwarf
./build x86_64 eg-amp-lv2-labs
./build moddwarf eg-amp-lv2-labs
./validate x86_64 eg-amp-lv2-labs

The reason for both x86_64 and moddwarf is I want to validate using valgrind as well once this is working.

1 Like