Modduo Advice re DAW and other connections sought

Hi

I am a keen twiddler and expert in nothing… I just like making sounds/noises that please me!

I have a couple of issues which I am sure have been addressed in the past, but at the risk of looking foolish am asking afresh for a little help on my points

I mostly use my Mod for guitar noodling, but now want to broaden my use to include midi keyboard and hardware and software synths

I have

PC with DAW (Ableton) connected by USB to

  • Novation Launchkey
  • Behringer Model D
  • Arturia BeatStep
  • Scarlett 4i4 (inc Midi In/Out 5pin ports)
  • Creative E-MU Xmidi 2x2 USB to 5 pin midi interface
  • Mod Duo connected via 5 pin midi to
    * FCB1010 controller

I want to be able to use the ModDuo as a midi instrument controlled via my keyboard. As standard, I am unable to see the Mod as a viable midi source from within my DAW.

I eventually found Audio Through USB - MOD Wiki (moddevices.com) and now the Mod shows up as a midi instrument on my PC. However, when I try to use it, I get no output. If I connect the XMidi interface to the 5pin midi port and select the appropriate midi output in my DAW, that works fine, but I do not really want to use the 5 pin port as that is used by the FCB1010.

I am afraid the advice found so far was a bit confusing constructed as it was over a series of submissions some of which discussed other similar issues not related to mine.

I have another issue which may be behind my problem. When I create a new pedalboard in the Mod Web interface, I get the standard patched through audio connections and an unused Midi input.

Occasionally when building / refreshing the pedal board, the Midi input disappears
image

For example, after refreshing the above view, I get this…

I would also appreciate being told how to disable the 3rd and 4th audio channels which I accidentally enabled by rushing through the guidance in the linked post above.

All help and guidance would be most gratefully received.

Thanks in advance

John

1 Like

This is enabled by creating the file with “audio” in its name. Just remove that file and reboot the unit.
I suspect this is why the MIDI plug disappears sometimes, though it is the first time I see such a thing reported.

2 Likes

@falkTX, thanks! I’ll sort it straight away!

methinks I shouldn’t mess around with things I do not fully understand!

cheers

1 Like

Well, where’s the fun in not messing with things you don’t understand? :wink: That’s how I learn new stuff!

2 Likes

@malfunction54 You have a good point. I shall carry on ‘learning’ (hopefully without breaking stuff!).

cheers

2 Likes

OK, in my quest to sort my issue I have found the following behaviour:

Midi Keyboard → PC → Ableton → XMidi Usb interface → ModDuo via 5 pin midi cable/port - Works!

Midi Keyboard → USB → Host Port on Mod Duo (keyboard takes power from Mod) Doesn’t work (although i can map synth controls in Mod Duo to controls on keyboard)

Is there a ‘configuration’ step I have missed?

Cheers

John

1 Like

What doesn’t work? The keyboard notes? But it works the assignments? Also, what is the keyboard?

1 Like

@jon yes. I am sorry, where I say ‘works’ I mean I get notes from the mod duo. In the second example, I do not get notes from playing keyboard but I am able to make control assignments in the synth (MDS DX10). In both connection routes, my keyboard is a Novation Launchkey 49.

Cheers

1 Like

This may be a silly question, but have you connected the MIDI virtual input to the virtual synth?

do you mean 'dragged and connected the blue midi ‘plug’ to the ‘socket’ on the synth? if so then yes (it plays notes if connected via the PC Interface and 5 pin port).

Please bear in mind that (as reported above) if I ‘refresh’ the web interface (I lose the ‘plug’ and connection to synth)

goes to this:

I don’t know if it is relevant, but seems odd!

Cheers

This is a new bug I haven’t seen before.

You are using 1.11.3 correct?
Do you any USB MIDI devices plugged in?

2 Likes

@falkTX

Yes, I recently updated to 1.11.3.

I have the launchkey 49 plugged directly into the USB Host port. I am unable to hear notes from the ModDuo, although I am able to assign controls to the keyboard.

I also have an old midi keyboard (5 pin DIN at both ends), if I use this, I can play the synth.

When trying the Launchkey 49, I disconnect the DIN cable and old midi keyboard.

Is that what you were asking?

It doesn’t seem to matter which connection is used, refreshing the web interface (pressing F5) causes the midi plug / connection to disappear

Cheers

John

1 Like

Good Morning all!

I seem to have found my mistake. By fiddling around with the Midi Ports settings in the Web interface (never used them before and completely forgot they were there!), I appear to have fixed my ‘perceived’ issues! I can now connect to Mod Duo over the USB to PC connection via my DAW.

The virtual Midi plug no longer disappears after a refresh.

Many apologies for wasting people’s time, though I appreciate the interest shown by contributors.

Roll on Mod Dwarf phase 3 deliveries… can’t wait!

Many thanks

John

3 Likes