Modduo.local not working for me

What sets up the DNS for modduo.local? The IP address is fine

I’m sure it worked on the first device I tried it on but has not worked on my current Windows PC or Ubuntu box. Is it perhaps last couple of test builds are not doing something?

PS I can always hack the hosts file but you suggest it should work.

This is something regarding avahi/zeroconf and mDNS.
When you say it worked on the first device, you mean the Duo? Does it still work now?

I meant I tried on one windows PC that is different to the one I am now using. Both have latest Windows !) though current is Windows Insiders.

Is not working for me on latest Windows device or Linux.

On linux, you need to have avahi installed. On windows, you need Apple
Bonjour. It is available on its own or as part of an ITunes install.

This should sort you out.

Ah, it’s very likely the original PC had that as had installed all sorts of crap on it :stuck_out_tongue: New one is nice a clean as I reset it.

I’m perfectly happy with the IP, especially as I keep the tab open at all times!

Just checking not another wrinkle.


If you don’t want to install from apple, you can install Cygwin and the avahi version for it.

Cygwin is a distribution of open source software that provides typical GNU/Linux software for running on Windows.

Thanks - I’ve known Cygwin very well for very long time. Though I prefer MinGW/MSYS.

Actually I have git for windows installed which includes both but only a few packages - I was messing about with a custom build to allow me to add other packages - maybe that would be useful

Well, what I meant is that Cygwin ships avahi as part of the distro.

1 Like