Netjack pluggin


#21

My mod-ui is now showing any plugins now with the exception of some pedalboards showing, this is after restarting everything, also it shows 'Failed to connect to MOD cloud" on the update button. Any ideas of why that could be?


#22

mine is looking fine (on 1.4.0.353).


#23

v1.4-rc1 is out, the first public release with this integrated:

I’ve updated the wiki page regarding audio through USB to match the latest changes:
http://wiki.moddevices.com/wiki/Audio_Through_USB


#24

What is the --opus option for jackd ? My version does not seem to recognise it !


#25

Also, I’m now running 1.4.0.370-RC1. I can’t see the slave ports on the Web UI. Have I got anything missing ?


#26

opus option is for audio compression, so it sends less data over usb.
not all jackd builds have this, depends on your distro. under a normal desktop distro you might not have this option enabled.
kxstudio has this though.

if you read the wiki page, there’s some bits you need to run inside the Duo, via ssh.


#27

Acutally, I have run the ‘touch’ and systemctl commands.

running jack_lsp -cpt on the mod shows that network is working. It is just that the ports don’t show in the Web UI. So I still need to do the connections manually via the mod’s shell.

Thanks for your answer anyway.


#28

maybe you named it something other than ‘slave’? that would explain the missing ports.


#29

I just used the command line from the wiki, without the compression option.

I’ll give it another go and will let you know the results.


#30

Hello,

I hope you are well !

the slave ports are still not showing (current version 1.4.0.380-RC2)

Here is the command line I used on my Linux Debian Jessie :
jackd -R -P 80 -d net -a 192.168.51.1 -C 2 -P 2 -i 1 -o 1 -l 4 -n slave -s

Then I logged on the mod and checked with jack_lsp -cpt that the physical ports are seen with the right name :

system:capture_1
mod-peakmeter:in_1
effect_3:in
properties: output,physical,terminal,
32 bit float mono audio
system:capture_2
mod-peakmeter:in_2
properties: output,physical,terminal,
32 bit float mono audio
system:playback_1
mod-monitor:out_1
properties: input,physical,terminal,
32 bit float mono audio
system:playback_2
mod-monitor:out_2
properties: input,physical,terminal,
32 bit float mono audio
system:midi_capture_1
mod-host:midi_in
properties: output,physical,terminal,
8 bit raw midi
system:midi_playback_1
properties: input,physical,terminal,
8 bit raw midi
mod-monitor:in_1
effect_1:Out1
properties: input,
32 bit float mono audio
mod-monitor:in_2
effect_1:Out2
properties: input,
32 bit float mono audio
mod-monitor:out_1
system:playback_1
mod-peakmeter:in_3
properties: output,
32 bit float mono audio
mod-monitor:out_2
system:playback_2
mod-peakmeter:in_4
properties: output,
32 bit float mono audio
mod-host:midi_in
system:midi_capture_1
ttymidi:MIDI_in
properties: input,
8 bit raw midi
mod-peakmeter:in_1
system:capture_1
properties: input,
32 bit float mono audio
mod-peakmeter:in_2
system:capture_2
properties: input,
32 bit float mono audio
mod-peakmeter:in_3
mod-monitor:out_1
properties: input,
32 bit float mono audio
mod-peakmeter:in_4
mod-monitor:out_2
properties: input,
32 bit float mono audio
ttymidi:MIDI_in
mod-host:midi_in
properties: output,physical,terminal,
8 bit raw midi
ttymidi:MIDI_out
properties: input,physical,terminal,
8 bit raw midi
effect_0:control
properties: input,
8 bit raw midi
effect_0:notify
properties: output,
8 bit raw midi
effect_0:out
effect_2:in_left
effect_2:in_right
properties: output,
32 bit float mono audio
effect_0:in
effect_3:out
properties: input,
32 bit float mono audio
effect_1:In1
effect_2:out_left
properties: input,
32 bit float mono audio
effect_1:In2
effect_2:out_right
properties: input,
32 bit float mono audio
effect_1:Out1
mod-monitor:in_1
properties: output,
32 bit float mono audio
effect_1:Out2
mod-monitor:in_2
properties: output,
32 bit float mono audio
effect_2:in_left
effect_0:out
properties: input,
32 bit float mono audio
effect_2:in_right
effect_0:out
properties: input,
32 bit float mono audio
effect_2:out_left
effect_1:In1
properties: output,
32 bit float mono audio
effect_2:out_right
effect_1:In2
properties: output,
32 bit float mono audio
effect_3:out
effect_0:in
properties: output,
32 bit float mono audio
effect_3:in
system:capture_1
properties: input,
32 bit float mono audio
slave:audio_to_slave_1
properties: input,physical,terminal,
32 bit float mono audio
slave:audio_to_slave_2
properties: input,physical,terminal,
32 bit float mono audio
slave:audio_from_slave_1
properties: output,physical,terminal,
32 bit float mono audio
slave:audio_from_slave_2
properties: output,physical,terminal,
32 bit float mono audio
slave:midi_to_slave_1
properties: input,physical,terminal,
8 bit raw midi
slave:midi_from_slave_1
properties: output,physical,terminal,
8 bit raw midi


#31

By the way, is there an easy way to modify the mod’s sampling rate from 48khz to 44.1 ?


#32

No, this is not supported in any way.


#33

This was my fault, sorry didn’t noticed one small but very important fact.
The client name must be ‘mod-slave’, and not ‘slave’. I adjusted all relevant pages that have this information (forum posts and wiki).

Try it out and see if it works.


#34

Thanks for looking into it !

You guys are awesome ! I really hope the mod will be a huge commercial success ! You deserve it !


#35

Hey, im having some issues.
I tested Azza script when I was at version 1.3 something, I remember needing to tweek some steps but can’t remember all I did… since that, my mod-UI shows a ‘Failed to connect to MOD cloud’ on the update icon ( but ONLY on Linux, Windows works fine and I’ve been updating from there since ) and it fails to render my pedalboard when I open (also, only on linux). I have already updated to 1.4.3 and this situation remains, thats my mod-ui problem.
I have another issue (more important to me now) with the audio through USB. I followed the wiki article instructions to get my audio from mod and I did it, but it consistently pops X-runs (even with a empty pedal board, just direct connections). When I record something, the track is all messed up. On my computer side, jack keeps printing

Wrong packet type : m
NetSlave : missing last data packet

and sometimes a X-run message like

JackEngine::XRun: client PortAudio finished after current callback
JackAudioDriver::ProcessGraphAsyncMaster: Process error

Any idea on how to proceed?

Cheers


#36

[quote=“lucastakejame, post:35, topic:1134”]
I tested Azza script when I was at version 1.3 something, I remember needing to tweek some steps but can’t remember all I did… since that, my mod-UI shows a ‘Failed to connect to MOD cloud’ on the update icon ( but ONLY on Linux, Windows works fine and I’ve been updating from there since ) and it fails to render my pedalboard when I open (also, only on linux).[/quote]
This sounds like some caching issues, try to open the web interface with a different browser on Linux to see if it makes any difference.

[quote=“lucastakejame, post:35, topic:1134”]
I have another issue (more important to me now) with the audio through USB. I followed the wiki article instructions to get my audio from mod and I did it, but it consistently pops X-runs (even with a empty pedal board, just direct connections).[/quote]
Was this working before for you?
If not, it might be that you need to update your JACK version. Using netmanager implies you have a recent enough JACK, regular Debian and Ubuntu distros do not have this :frowning:


#37

@lucastakejame

Debian Stretch uses jackd2 version 1.9.10.

Getting the latest source (1.9.11-RC1) from the github repo and building it on Debian is straightforward.


#38

I wouldn’t say straightforward. if you install jack from source you’ll end up (by default) with jack libs in /usr/local/lib/ and /usr/lib/x86_64-linux-gnu/ which is really asking for trouble.


#39

Could you elaborate please ?


#40

Well, on Debian jack libs will be installed on /usr/lib/<arch>/.
When you build JACK from source, without passing some specific configure flags, it will install its jack libs to /usr/local/lib/.
With this you end up with 2 different JACK versions installed on your system, which is really asking for trouble.

Your qjackctl might be setup to launch /usr/bin/jackd (which is the Debian’s JACK), but then it will use JACK libs from /usr/local/lib/ since jackd has no rpath linker settings. (/usr/local/lib takes preference over /usr/lib/).
The core of JACK has changed since 1.9.10, now uses futexes for sync instead of posix semaphores for example.
So on this case the jackd and libjackserver.so will conflict with each other, perhaps not even start.

Without the manual prefix, running jackd will call /usr/local/bin/jackd and get the correct libs from /usr/local/lib/.
But then an application might somehow use the JACK libs from /usr/lib/ (hardcoded path), which will generate conflicts too.

You might think that building JACK with --prefix=/usr is enough, but remember Debian has multiarch, so prefix=/usr will still generate conflicts (/usr/lib/libjack.so vs /usr/lib/x64_64-linux-gnu/libjack.so)
The actual configuration command for Debian is ./waf --prefix=/usr --classic --libdir=/usr/lib/x64_64-linux-gnu --alsa --dbus --firewire.
KXStudio builds add --clients=256 --ports-per-application=2048 --autostart=dbus.

Even if you manage to build it correctly, you now broke 32bit clients on a 64bit system, as you have to build that taken into consideration Debian’s multiarch setup.
You’ll have to build with “-m32” in CFLAGS, CXXFLAGS and LDFLAGS, custom libdir, and then do a manual selective install of the jack libs in order to get 32bit clients working on a 64bit Debian system.