New Peripherals Incoming - Beta Testing Phase


#41

I heard that there is a limit of four control chain footswitches in one chain from the Duo.
Is this going to be the same for the control chain expression pedal?

If the limit is due to available power, then it is possible to purchase an external POE supply with more power and add more control chain peripherals?

Just a thought…


#42

And for those converting from feet to meters;


#43

just got my beta footswitches unit today… when i connect the MAIN jack on the footswitches to the “control chain” jack on the DUO it lights up ok, and the displays seem to be working. but, hovering over the control chain icon in the browser GUI, it says “no control chain devices connected”.

my MOD is at 1.4.0.370-RC1

do i need to do something to get the footswitches recognized?

btw… i have the arduino shield as well, but haven’t programmed my arduino UNO to do anything with it. i’m a newbie on that end of things, but if someone can show me a quick arduino upload that will make the shield recognizable to the MOD, then i can test whether it’s a problem on the MOD end, or the control chain device end.


#44

I seem to have the exact same situation… Mod Duo v1.4.0
Footswitch ext. FW ver: 0.0.5


#45

For arduino stuff with control chain, see https://github.com/moddevices/cc-arduino-lib

I wasn’t able to reproduce the issue about no control chain devices registered, if someone else also has the issue let me know.
I’m investigating possible causes…


#46

alright, i’ve set up my arduino with the shield, installed the libraries in the arduino IDE, and loaded the “Button” example code. the IDE verified and uploaded it to the arduino with no errors.

when i connect the arduino with the shield to the MOD via the “MAIN” jack on the shield, the MOD gui also says “no control chain devices connected”. :frowning:

so i guess that points to some issue in the MOD, since both peripherals fail?

thanks for investigating, @falkTX – let me know if there’s something i can test!

btw… i’m on ubuntu, and i checked the MOD gui in both Firefox and Chrome, just in case it’s some weird browser thing – same result in both browsers.

also, both LEDs (amber and green) on the MOD control chain jack are ALWAYS lit – it doesn’t matter whether anything is connected or not, and there’s no change (not even a flicker) when i connect a control chain peripheral. is that normal? (there is some activity in the LEDs during the MOD bootup, but once it’s up and running they stay on no matter what.)


#47

Same behaviour here - both LEDs on my MOD DUO control chain jack are also always lit; no signs of in/out activity…
I hope you come up with a remedy @falkTX

  • looking forward to a solution…

#48

Foot Pedal working fine here, will try to give the arduino board a go soon…


#49

Hi guys,
I had the same issue when plugging the footswitch into the mod the first time : the footswitch lit up correctly but the browser GUI said “no control chain devices connected”. I rebooted the Mod, still had the problem and then plugged out and plugged in the footswitch again and for no particular reason, it started to be recognized correctly by the mod.
So just plugging in/out the footswitch might solve your issue !


#50

thanks, @romi! i’ve done that a bunch of times… but i’m willing to keep trying! :smiley:

…but you know what they say about the definition of insanity!.. :stuck_out_tongue:


#51

i also tried chaining the footswitches and the arduino shield in both possible orders… no success.


#52

Have you tries reinstalling the firmware on the Mod?

Sounds like something strange is going on if the orange led is lit up when nothing is connected.


#53

i haven’t done that. i’m now also seeing some times when a control chain device IS connected but the orange LED ISN’T lit.

ok… new firmware it is, then! :slight_smile:
…i’ll report back…


#54

On mine when I first plug the pedal in the yellow led lights up solid for a second or so and then pulses with it off more than on.


#56

ok… manually reinstalled 1.4.0.370-RC1. still no joy.

the orange LED ~sometimes~ toggles each time i plug in the control chain cable. i.e. if it starts ON and i remove the cable, then when i plug it back in the orange LED sometimes then goes OFF. and vice versa. but it’s not consistent.

seems weird.

btw… with 1.4, i’ve also been observing more times than usual where the MOD doesn’t boot successfully – i.e. sometimes hanging at the splash screens.


#57

mmm, I haven’t seen a hang at boot either.

I’m guessing the Moddevices guys will have an idea what might be the problem.

I guess you have checked this but you have the cable connected to the MAIN port at the back of the foot switch? I had it in the wrong one first time I tried!

I don’t know your linux understanding but I just had a look at the mod duo, the control chain stuff is handled by /usr/bin/controlchaind, if you ssh to the mod is that process running? On mine I see /usr/bin/controlchaind /dev/ttyS3 -b 115200 -f

you can use the following to find it: ps -ef | grep control


#58

Hey guys.

Can you please check if the following image fix the issue?
image: http://download.moddevices.com/releases/testing/modduo-v1.4.0.374.tar

You will need to do a manual update: http://wiki.moddevices.com/wiki/Releases#Manual_update


#59

@AndyCap: yes, controlchaind is running.
@ricardocrudo: i’l try the new version and report back…


#60

!SWEET!

…i’m now sitting here madly switching one plugin with my control chain footswitch, and another with my arduino shield button!.. :nerd:

look out universe…

thanks a ton, @ricardocrudo!

however: i’m now noticing a strange thing about control chain device assignments…

if i assign some control chain actuators to some plugin parameters and save the pedalboard, then if i unplug the control chain devices and plug them back in, those actuator assignments are lost. am i missing something about how to make control chain assignments persistent?


#61

The assignments are lost when you remove a control chain device.
Soon we’ll revise and discuss what to do in this situation, but for now the focus is getting the devices working first.