New Peripherals Incoming - Beta Testing Phase


#62

cool… thanks, @falkTX!

i get it: for now “beta” does not equal “take-it-on-stage-tonight”, contrary to much of how i operate… :smiley:


#63

YES!
Thanks a bunch, ricardocrudo,
That v 1.4.0.374 made all the difference - now it works like a dream, wonderful!
Great concept - the Mod Duo - love it! :slight_smile:


#64

Hiya.
I have encounted an error when trying to assign pedalboard presets to the external controller.
It does not assign it to the switch.
I have updated to the new update: modduo-v1.4.0.374.tar3
But still with no results.
Assigning to the MOD switches is successful though.
Will experiment again today to see if I can fix the issue.


#65

Issue still persists that I cannot assign pedalboard presets to the external controller.
Another bug shows that when assigning to an external switch, it only shows external foot switch 2-4 and not foot switch 1, even though external foot switch 1 is not assigned to anything.
Possibly a global reset of the external and internal foot switch would be handy as it can get confusing where each switch is assigned.


#66

Right now you can just remove the foot and connect it again.
It will forget all previous assignments.

I’ll see what’s going on with pedalboard presets.


#67

Great thanks.


#68

Hey
Tried to use the Arduino Shield today, but wasn’t succesfull till now.
I managed to load the example onto the Arduino, and when I use the switch the red LED toggles.
So I’m quite sure the program is running.
But the MOD never recognizes the Arduino. Even updatig to the 1.4.0.374 didn’t help…
The orange LED on the CC-Input also never changes when i plug the cable in and out.
I tried it with the Arduino UNO and Due.

Any futher advice?

Update:
After pluging in and out for several times it finally worked. Sorry for bothering you.


#70

Hi,

Just received my footswitch in the mail yesterday, so compact! looks really great together with the Duo, nice work on the ergonomics everyone!

I understand that for now the switch will forget all assignments when unplugged, as long as I have it plugged in when powering up the MOD will it remember the assignments?

Also, wondering if the backlighting in the footswitch displays can be made a bit brighter, it is a bit dim to read the pedal assignments in a dark room/stage as it is now IMHO.


#71

hey @GMaq… how’s it going? over here, as long as i have the footswitch connected whenever the pedalboard loads (whether at power-up, or by loading from the library), the assignments are remembered.

i do agree about the display being a bit dim. personally i’d like the brightness of the MOD and the footswitch to meet each other halfway… i find the MOD a bit bright! :smiley:


#72

Correct. Removing the control chain device will remove the assignments from the current pedalboard.
So if you need them, don’t click save afterwards.

If you boot without the footswitch connected, just load the pedalboard again to get the assignments back.


#73

I got my foot switches last night and did a little experimenting this morning.

It seems that if you have a heavy CPU load pedalboard, the DUO has a hard time connecting to the footswitch if plugged in after start up. If the footswitch is plugged in before startup then it seems to do okay.
My pedalboard uses about 75 to 80% CPU. When I plug in a footswitch it spikes up to 100% and doesn’t recognize the footswitch.

I built a very simple pedalboard for testing and the Duo had no issues recognizing the footswitch when plugged in after turn on.

I have two footswitches and I was having a little difficulty when I daisy chain them. I didn’t have much time to test different scenarios but I will try it some more tonight. There seemed to be the same issue with CPU heavy pedalboards. In fact, one time that I had one footswitch plugged in and working, I plugged in the second footswitch and the Duo said control chain device disconnected… That was strange…

I will report back with some more findings tonight or tomorrow morning…


#74

Please give this build a try: http://download.moddevices.com/releases/testing/modduo-v1.4.0.384.tar
It reduces CPU load for specific plugins and messages. Specially for at1, tuna, and stepseq.

Regarding 2 footswitches, they’ll not work if you connect both at once (ie, plugged in during boot).
This will be solved in a footswitch firmware update soon.


#75

Thank you @falkTX!

I will download and see what happens.

Looking forward to the footswitch firmware update.


#76

Still having the same issue when hot plugging the footswitch…
The workaround is to make sure to have it plugged in at turn on or hotplug only with simple, lower cpu usage, pedalboards…


#77

Another issue…
I’m sure you already have seen this…

When powering on with footswich connected, the assignments don’t always get made. The footswitch is recognized but the assignments are not always made.
I sometimes turn on the unit and the footswitches show the assignments right away. Other times I need to re-load the pedalboard.

My next test will be to go between pedalboards in a bank.


#78

Difference in Footswitch beviour
plugin: Loopor

so I assigned Activate to MOD: Footswitch 1

  • everything works wonderfully,
    exactly the way you’d expect
  • “Ditto” behaviour, very nice, indeed!

but assigning it to FootEx: Foot #1
does not work at all, no threshold action,
button behaviour random, or…?
…how come?
What’s the difference?
I guess it’s nothing to do with the plugin - Loopor
but there’s a difference in footswitch behaviour,
please inform what to do to make:

FootEx: Foot #1 behave like MOD: Footswitch 1


#79

The MOD Duo’s included footswitches and the control chain ones do not work the same way, software-wise.
I will investigate to see if one of them is doing something wrong, but I suspect it might be a question of timing. The loopor plugin makes some assumptions regarding how early/late someone pressed the footswitch.
I will do some tests.


#80

2 posts were split to a new topic: Footswitch extension behaviour


#81

just noticing a small issue with the physical construction of the external footswitch…

to aid in my physical pedalboard mounting scheme, i need to remove one of the rubber feet. not a problem; just have to remove the bottom panel to undo the nut 'cuz the rubber feet use bolts rather than screws. when undoing the bottom panel screws i noticed that a lot of them were loose, and a couple wouldn’t thread out properly. then, when re-fastening the bottom panel, it’s clear that the screw-to-hole engagement is not tight and secure - they don’t screw in to a point at which they’re clearly tight and then stop. rather, you have to be very careful to only marginally tighten them or they’ll strip, and a few of them were already stripped.

inspecting at the screws, it looks pretty clear that it’s not the screws that are stripping, but rather the holes in the footswitch body. are you seeing this on other units?


#82

Hi.
Is it still possible to get Arduino Shield for test ? Or must I wait for official release now ?
Thanks.