Newb query: Not able to download shared pedalboards to my Dwarf

Hi there. Thrilled to have received my Dwarf yesterday. Since then, I’ve been spending my time just getting orientated to operating environment - both of the h/w unit and the online space.

One of the things I want to do right away is download a few of the pedalboards that others have created and shared, just so I can closely study some working examples before trying my hand at creating my first one myself.

However, when clicking the “Try Now” button to any of them, and even despite getting a message that says “Victory! Your MOD Duo is now loading the pedalboard you picked… Rock on!” when I go to the Dwarflocal site, or anywhere on my account, I don’t see any of these pedalboards. Like, dudes, where are you hiding on me?

I have this nagging feeling I’m missing something dead obvious that I’m going to feel dumb about once somebody explains it to me, but I have to ask since I couldn’t find any relevant info on the Community or Pedalboards pages. Plus I’m a newb.

Any advice on how to resolve this issue would be much appreciated.

Cheers
Frank Paul
Vancouver, Canada

1 Like

This is often due to browser blocking incoming signals from outside.
Try having the web gui open on a private session, or some other mode without addons that could block such things.
Maybe also try a different browser.

3 Likes

Awesome - thanks Filipe! I tried your suggestion of downloading within a private session on Edge and it worked just fine. Thanks so much for steering me in the right direction and resolving my issue. All the best, Frank in Vancouver

7 Likes

Weird update: After having initially had to use a private session on Chrome to facilitate this, I notice that regular browsing now seems to work fine and no problems. Sometimes I think that browsers have a mind of their own! :smile:

3 Likes

There are indeed some weird things happening sometimes with the browsers.
I can tell you that just today had a DuoX working perfectly on Chrome and not working on Firefox. Same computer and same device.

I find that in tech, there is often an inverse correlation between size of company and reliability/quality/dependability of the products they put out. So, please, MOD Devices, don’t ever get too big! :smile:

3 Likes