Pedalboard Cuts Out Regularly [FIXED]


I just received my replacement Mod Duo X (apparently my original unit was not properly activated) and fist updated to the latest firmware out today (Sept.16, 2019 - version and then imported my previously working pedalboard onto it. I also update all plugins from the store with an empty pedalboard, and rebooted the device.

It cuts all audio out for 5 seconds approximately every 30-40 seconds when playing a USB-connected keyboard.

How to reproduce

  1. Load this pedalboard onto a Mod Duo X with v1.7.855 firmware -
  2. Plug in a USB keyboard (I am using an MAudio Keystation 49e)
  3. Play for 40 seconds until it cuts out.

Expected/suggested solution

This pedalboard worked fine on my old unit with the previous version of the firmware. I saw this behavior with a pedalboard that had a trial plugin on it, but this one does not have any trial plugins.

Additional information

  • release: 1.7.4
  • controller: 6FB8002

Also provide some information about your system if possible.

  • Operating system: Windows 10 Pro (10.0.18362)

FYI - I uninstalled the only trial plugin I had installed (unknowingly installed when trying an online pedalboard) and rebooted and it still suffers from the same issue.

I also loaded up the stock “Dual Acid Machine with Delay and Reverb” and it does not have this problem. Seems to be an issue with the pedalboard I restored from my other device on the older firmware.

I’ll try re-creating it from scratch this week to see if it fixes it.

1 Like

any progress on this?

note that if you are able to install or update plugins, then device did register successfully.
the audio cutoff sounds really like plugins running unlicensed.
can you tell me what MOD serial number you have for your duox? (just need the last 3 digits)

I haven’t had a chance to rebuild the pedalboard yet but I will try tonight. Last three digits are 083.

The licenses are there for that unit, so that is not the issue hmmm

Let me know how it goes on your side of things then, thank you

Recreating the pedalboard with all the same plugins produces the same result. Still cuts out.

However, it is only the keyboard signal chain. The only “paid” plugin there is the Shiroverb, which it says I have purchased. However, I did import all my settings/plugins from my old pedal. Perhaps it got messed up license-file-wise? I tried removing and re-installing that plugin and it did not fix the problem.

In fact I have narrowed it down to just that plugin. Dropping it onto a pedalboard by itself suffers from the same cutouts. I will try removing it and rebooting the pedal. If that doesn’t work, let me know if there is something you can do on your end, or if I can fix it by SSH somehow.


Uninstalling and rebooting did not solve the problem. Let me know what I can try next, please.

OK, SSH’ing into the device and looking at the keys files, it looks like they are both for serial number ending in 063 (my old pedal). My new one is 083. So apparently I should not have tried to export my data from my old pedal to the new one. Is it possible for you to send me the original keys for my unit (serial number ending in 083)? You can email me at mark dot melvin at gmail dot com.

you mean the keys in /root/data/keys? those are generated automatically when you open the web gui.
try deleting that folder and rebooting the unit

Thanks, I was afraid to remove those files. I deleted the folder and problem solved! The new keys files have the proper serial number in them.

Thanks for your help!


Great, I was unaware of this serial number change, but anyway good to see it resolved.
I edited the thread title to mention it is fixed, hope you do not mind.

That’s great - thanks!