Release 1.1.2

Hello everyone, another 1.1 bugfix update is here - v1.1.2 aka “Fix it! Fix it! Fix it!”

This bugfix is mostly for solving boot and installation issues.
With this update the MOD will completely boot even if the user data partition is unmountable.

Since 1.1.0 a quick system check is performed on the data partition as needed, and mounted read-only if problems are found. The web interface is now fixed so it can still run on this case (read-only file system).
If you have this issue, reinstalling v1.1.2 or a later update will fix it.

Next, we fixed an issue in the bootloader that prevented the main system from booting, and thus entering restore mode instead.

And finally, if an automatic update installation fails and the MOD enters restore mode again, it will keep reinstalling the OS until it boots normally again. :slight_smile:

Hopefully with these changes the amount of install failures is reduced considerably.

The next time you open the MOD web interface you’ll receive an update notification.
Just click on the tooltip icon in the bottom-right when that happens, then ‘Download’ and finally ‘Upgrade Now’.
Wait for a few minutes while the MOD updates itself automatically. :slight_smile:

For those that like the old way, here’s the download link:

And here’s the changelog:

  • fix boot into restore mode after an update under certain conditions
  • fix web interface to load under read-only file systems
  • automatically reinstall OS if update via web interface fails
  • check user data partition when installing updates (applies to future updates)
  • do not fail to boot if user data partition is unmountable
    (create a virtual disk on RAM for such cases)

We hope you’re enjoying your MOD Duo.
Please let us know of any issues!


How long should this take? I started the upgrade process about 30 minutes ago (from the gui) and it’s been cycling back and forth between the red and blue lights ever since. The display on the mod still shows “checking file”.

Gave up and unplugged, then powered up via the left footswitch/button method. Tried the manual update method with 1.1.2 with the same result. Powered down and powered back up as before, installed 1.0.6 and things are fine now.