Release 1.11.0-RC1

Bug when loading pedal board from previous firmware build.

This has been repeatedly tested and replicated on my end.

When building the same board on the RC, I have zero issues. If I load the old board from my library, the dwarf locks up as soon as parameters are changed.

These videos will be unlisted so only those with a link can view these. I won’t be making them public facing.

Edit: so after further testing, I loaded an old board that I had made and saved zero parameter mappings to the device; what I found was that I can assign the parameters on the new firmware without any issues or freezes.

I’m wondering if maybe there is something going on with loading boards that already had previous device mappings saved.


Will this plugins be available as standalone too?

You mean in the plugin store?

I don’t recall the decision on that, @Jan will know better.

For the issue reported by @Elk_wrath , good news @Jan has identified the issue.
The way we do list-parameter assignments has changed, loading old pedalboards gives us old behaviour and these are conflicting. So we need to force the newer method. (in technical, specific terms, the “step” size of an assignment on v1.11 describes the number of items in the list, where in v1.10 and below it was ignored)

We need a RC2 then :slight_smile:


Snapshot problems - I set up a new pedalboard, saved 4 or 5 complex snapshots and then the GUI refused to enter the load/manage snapshots list. I rebooted the Dwarf and all but the first snapshot had disappeared. I had, before the problem arose, changed between the other snapshots without a problem. Just realised that I hadn’t saved the pedalboard, so the loss of snapshots is explained, but the refusal to enter the load/manage is the main one! I’m annoyed with myself, I normally only have to remind other people to save while working!


Added later: I’ve just run through everything I was trying to do earlier (saving after every change!) and it worked fine - hopefully just a one off.


Regarding the plugins, yes once all is fully tested these will also be available in the plugin store :slight_smile:


Don’t know if it’s a new expected behavior but when I drop a new plugin on the pedalboard (or move it) the entire pedalboard is zoomed out. I’m using Firefox 93 on Windows 10.

The Chrome browser is recommended for the Mod devices. I once tested Firefoy as well and I also had issues. Just check it with Chrome.

Same happens with chrome.

Where is this recommendation coming from?
We should change it.

I rarely use Chrome here, 99% Firefox and Chrome only for some specific google pages.


Yeah Firefox here and everything is fine

I tried this release and I have a lot of freeze with my Mod Duo X.
Can’t explain when it happens. Nothing is responding, but I can still hear sound.
I think that for the first time I’m going to downgrade to a earlier version…

1 Like

Is this the setting? How it should work?

An element of a list is just activated when you select it (scroll over it) and click on it. Instead of just selecting it. I guess it’s that.

Which kind of list? Pedalboards? Snapshots? Single parameter list?

All lists available on the device. If I’m guessing well.
I call here the master @falkTX to some clearance :wink: “ground control to major tone”


The tone shifts accidentally to @Jan :wink:


Selecting DIRECT value doesn’t make any differences with CLICK while scrolling

  • Banks list
  • Pedalboards list
  • Snapshots list

It works correctly only for single parameter list. Don’t know if it is the expected behavior.

@redcloud you are right, this feature only relates to lists in control mode.

It allows to switch between the old behaviour (every turn selects the item right away) and now added, a way to scroll through a list without selecting anything until the encoder is clicked.

We had some feature requests on this, as it makes plugin presets or tempo dividers in a live performance a lot more usable :slight_smile: