RMPro and FOMP Reverb block output

Description


FOMP Reverb has no signal on it’s outputs when it’s in a pedalboard that autoloads on power-up. (Duo X)

How to reproduce


  1. make a Duo X pedalboard with FOMP Reverb in it.
  2. save it and re-boot.
  3. FOMP Reverb has no sound at its outputs – doesn’t matter if it’s active or not.
  4. re-load the same pedalboard from the library, and it then works fine.

Expected/suggested solution


FOMP Reverb should just work, without having to manually re-load the pedalboard.

Additional information


…makes me nervous about using this great-sounding reverb; can i really be certain it’s going to function after a manual re-load? it ~seems~ to always come back, but it’s a bit crazy-making! :stuck_out_tongue:

  • FOMP Reverb: version 0.0-10
  • MOD release: Duo X running 1.11.0.2497-RC2

Also provide some information about your system if possible.

  • Operating system: macOS
  • System version: Big Sur 11.6

We tried to replicate the issue and we were not successful in doing it.
Do you have more info about the bug? Perhaps other plugins that you have always-on those pedalboards?
Do you have all the plugins updated as well?

I think this only happens when loading the PB while the unit boots up.
Often comes from plugins not initializing memory correctly, so it will have random garbage in memory and could potentially be used as the first source of audio input. I recall some plugins having issues like this, which we promptly fixed. This one is new.

1 Like

seems like that sort of issue, because a meter on the output of the offending plugin registers -inf.

i’ve removed all the extra things in the pedalboard, and narrowed it down to some kind of interaction between the FOMP Reverb and RMPro. in the pedal board linked here, i’m seeing -inf at the output of the RMPro, and also sometimes at the output of the reverb. re-loading the board doesn’t always solve the issue.

cheers!
.ptk.

Hey Plutek,

When I get home from work, I’ll try this out and see if I can replicate it as well.

2 Likes

note that, when the output of the RMPro is -inf, anything downstream of it also is non-functional. i.e. even if i connect a test signal generator directly to the device output, it doesn’t work.

ok, re-testing both this minimal board and my original performance board where i first noticed the issue, re-loading the board is usually NOT fixing the issue, so i’ve got to replace RMPro with other tools for now.

what a strange “perfect storm”… RMPro really sounds very good, and the FOMP reverb is the best in the MOD “ecology” for my horns. this is the first board i’ve built since purchasing the RMPro, and i was really looking forward to taking it to the stage.

:frowning:

Hey Plutek,

So I’m trying on the dwarf, just using the FOMP and RMPro plugin.

I’m on RC 1 still, and I cannot replicate the issue.

Currently loading your pedalboard and will test.

I’ll load RC2 after this, and see if there are any changes.

EDIT:
So I tried both RC’s with the pedalboard you posted, and I can’t get the same results.

This is on RC2

I’ve tried a few different times, and it’s fired up each time.

Maybe this is duo x specific?

2 Likes

hey @Elk_wrath thanks a lot for testing! yeah, i guess it looks like it must be specific to the Duo X.

1 Like

Do you have a Limited Editions DuoX?

yes mine is an LE, @jon

1 Like

That helped a lot! We managed to reproduce it. Bug report was done and waiting to be fixed :wink:

4 Likes

beautiful… great to hear!

1 Like

hey @jon …just curious: is this a plugin bug or a system bug?

Quite honestly I don’t know. But I think @falkTX can give you a better answer.

1 Like