Snapshot clicks and pops with reverb ir

I’ve tried switching between snapshots with different mono reverb IR’s (1 short and 1 long) and I always get an unpleasant click or pop as I change. A solution I found was to run 2 instances of LSP mono reverb IR plugin and use a switch box to midi A/B between IR’s. This is seamless but the CPU gets maxed out so is not going to fly.

I’ve tried various other ways of quickly switching away and back on a single instance of the LSP plugin using the switch box and doing the snapshot change in between but the issue remained.

So, that’s my long winded way of asking if anyone might have other suggestions as to how I could avoid these noises on snapshot change?

This is expected because when you load the different snapshots the values jump to the new ones without any sweep.

Yeah…at least for now this may really be the best solution.

Most likely your problem is also with the IRs that are requiring a lot of CPU usage. Have you experimented with “less heavy” IRs?

That sounds suspiciously like a new feature request :grin:

I’ll certainly try some shorter IR’s to satisfy that curiosity but I have very specific requirements that use the longer ‘Bloom’ presets from the midiverb 2 and would have liked to use the Duo X to accurately replicate these.

In any case, thanks for your reply. I have a few more ideas/workarounds today I will try and if successful I will post them here for posterity.

2 Likes

I have some clicks while changing time with some delay plugins, is it similar clicks as yours in here Delay tester - MOD Devices ?
I notice this when I use midi sync to get the tempo from another musician computer, made this test pedalboard to check different plugins to search where the problem comes from.

The Bollie Delay and Gaffa SHIRO have no problem to handle changing the time without clicks.

1 Like

Not quite. Your’s sounds to me like it’s part of the dry signal which is then being processed by the delays; is that your experience? Mine is more of a single click/chit sort of sound so not sure if same issue.

After some messing around, I managed to get rid of the noise going from short reverb to large by putting an early reflections plugin before the LSP IR plugin but looking at some sort of ADSR single shot control of a gain module to handle the return journey to the short reverb again. If it works then it might be slightly elaborate but will keep looking for the most elegant workaround.

1 Like

No, it is only on the wet signal, could can try with the TAP Stereo Echo to change the time to ear those clicks.
I’ve checked with the rkr Reverb, changing the room size makes exactly the same clicks. Sadly changing the room size or delay of the Shiroverb MkII, FOMP Reverb… makes the same noise.

Cool if you find a solution, but I agree, it’s not quite elegant ! Hope the plugins could be updated with some clean solution.

Eventually something for us to check what can we do. I will save it as a request so we talk about it :wink:

2 Likes