Tuner display freezes after some time

I have experienced this a few times on my ModDwarf. The tuner will work, but then after some long time (I don’t know exactly but seems somewhere between 10 minutes to an hour) the LCD display freezes. The rest of the mod seems to work after the LCD freezes though (and all LEDs light up in response to music), and I can press the switches to exit out of the tuner and renter the tuner mode, at which point the tuner works normally again. But after a while it will freeze again.

1 Like

It seems to I can’t create new thread so I’ll reply here since it related with the tuner. The tuning process on dwarf is quite strange, sometimes it ignores the notes, also it shows the note and will not change even if I’m turning the tuning. I had hx stomp and used to turn and look at changes same time, so I could tune each string in about second. Here I should pick, then look, turn, pick again, wait for the value. It’s kind of frustrating.

Hi Ildus,
Thanks for reporting this issue.
First of all, I updated your trust level here in the forum, so I believe that you will be able to create new threads…please let me know if you don’t.
What you are describing is indeed a weird behaviour for a tuner. I will pass it to the developers and understand the “why” of this".

On potential causes for this issue:

  • Isn’t your input gain too low? The tuner has a threshold value, so the input signal should be above that.
  • We can lower this threshold, but it’s the first time that we are listening to this issue, so we would rather be sure that the input gain is loud enough

@jon how I can check on the device that’s the input is lower than the tuning’s threshold? and maybe it’s worth make it customizable?

Although it seems a reasonable request, in theory, I’m not 100% sure if it is in practice. This will make the tuner less accurate since it may enhance the noise of instruments/mics connected, current noises, and the noise of the device itself (even if you can’t listen all audio devices have some sort of noise).

You can’t check it directly, but I suggest you to go to your settings and raise the input gain (Menu Button > Settings > Audio Inputs)