USB Connect Failed : cdc_subset and netdev timeout usb0

you are the only one I know that has this issue.

so technically, I do not know how to start to debug this.

OK - I thought you had seen previous issues (but not 100% reproducible?).

Anyway - that means that perhaps this laptop has a strange network config.
Its a pretty-much standard Ubuntu 20.10, with a different desktop running (Lubuntu, with my DWM setup on top). Didn’t change any of the network backend/config stuff… so would expect it to work transparently.

Are linux users expected to have to run sudo ifconfig <dwarf_ethdev_name> up?
Without that, I can’t even ping the Dwarf. With that command, ping and nmap work fine, but ssh and web UI don’t work as expected…

DMesg (with NET+MIDI mode) doesn’t show issues with latest build:

[  347.485978] usb 1-2: new high-speed USB device number 6 using xhci_hcd
[  347.636138] usb 1-2: New USB device found, idVendor=1d6b, idProduct=0104, bcdDevice=32.10
[  347.636141] usb 1-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[  347.636142] usb 1-2: Product: MOD Dwarf
[  347.636144] usb 1-2: Manufacturer: MOD Devices
[  347.636145] usb 1-2: SerialNumber: 00001
[  347.641591] cdc_ether 1-2:1.0 usb0: register 'cdc_ether' at usb-0000:00:14.0-2, CDC Ethernet Device, 12:00:00:ff:ff:ff
[  347.654491] cdc_ether 1-2:1.0 enx120000ffffff: renamed from usb0

So it seems the cdc_error can be ruled out with this config/build: but the problem remains - why doesn’t it work as expected?

Usually network-manager (or whatever background service the desktop uses) takes care to set up the MOD network.
The unit has a DHCP server inside, which just makes this all work automatically usually.
You have other MOD units right? do you have to manually run anything for them?

perhaps it is just the CLI command that needs tweaking, try setting the subnet at the same time, like:

sudo ifconfig enx120001ffffff down
sudo ifconfig enx120001ffffff netmask broadcast up

btw, you cannot use as the address during “up”, as that is the address of the device.
the ifconfig command lets you set the IP of the host-side interface, not the gadget-side one.

1 Like

Quick info by the way :-). Since I still have problems with my Windows computers and the one that was working went out with the last Windows update, I have now installed a fresh Ubuntu on it. This allows me to access the Dwarf without any problems. So I don’t think it’s a general Linux-problem.


Ok noted, I’ll test that when I get the chance (tomrrow or later…) will report back when I have details!

Yes agreed that is for the Dwarf itself - I’m so used to typing ping that it just types itself now!


Hi all - Received my dwarf yesterday. Coming into the same issue as outlined by in5y372 in [Solved] 404 for Quistart

I didn’t see any real solution and haven’t been able to find the same issue posted elsewhere. If you prefer me to make a new post I can do that.

What I am doing:
Booting Dwarf completely only plugged into power. Making sure usb-b mode is set to Net + MIDI (Windows).
Plugging in the USB.
Windows recognizes it for a minute or so, and then you hear the hardware disconnect sound.

Under device manager --> Universal Serial Bus Controllers there is an item Unknown USB Device (Device Descriptor Request Failed)
Clicking into it the error given is
Windows has stopped this device because it has reported problems. (Code 43)

A request for the USB device descriptor failed.

I’ve tried to manually update the driver found on the troubleshooting page, and get an error:

Please let me know if you need anything from me for further troubleshooting.

Hello, after a long time I have tried it again with Windows and with the current firmware also still the same problems.

Currently it looks like this with me:

  • 2 Windows systems tested and do not work
  • 1 Ubuntu works, if I switch on the Dwarf before the computer is booted. Simply plug off and then plug in does not work if the dwarf is swited on after the computer is up.
  • 2 OS-X Macbook are working

If this should be the case with even more people, I’m afraid that even more manpower should be put into a solution, otherwise it could quickly lead to frustration for many when rolling out the normal dwarfs.

1 Like

We are aware of a few issues regarding the usb-b side.
This is an issue deep in the kernel driver (dwc2 in this case).

I have been personally keeping up with kernel developments regarding the dwc2 driver.
In the worst case we have to fix it ourselves.


I’ve tested on 4 windows computers all running windows 10 and all having the same issue. I will grab my wife’s mac later and test on it.

Hey @Randalhicks let us know the result of the attempt on the MacOS. This will help us sorting out the issue.

Tested on it late last night. Switched USB B to the default (option 1) and plugged it in. Read it right away and GUI loaded on first attempt. Worked great.

1 Like

Adding a note - still nothing with using USB-B and windows. I found a random bluetooth adapter while going through some old boxes today and was able to get it connected using bluetooth.

We have a possible fix for this coming soon, just need to verify things internally first.


Hi - Any update on this issue? Seeing that production devices are starting to ship, but to my knowledge there is no way to use USB to connect a dwarf to windows 10?

turns out the windows-specific “fix” breaks the setup for any other OS, so it is not something we can push.

Today I connected my Dwarf to my Windows 10 notebook for the first time in a long time. It connected without any problems this time. For whatever reason.On the Dwarf was still the penultimate firmware version and it has then successfully updated itself. Maybe Microsoft has turned something with the last updates, that it works now again. Strange, strange, but I thought I should share this :-).

1 Like

to be fair… microsoft keeps pushing updates and then rolling them back after it turns out something unexpected broke.
it has become very difficult to assess if something really works or not, the updates seem to be pushed differently per region and per device :confused:

maybe situation will be better with windows 11, who knows.

Sigh, after I had to reinstall my computer I can’t get on the Dwarf again. It feels like there must have been something in the Windows updates that broke the connection again. I get the Dwarf again only as a serial usb device indicated. Reconnecting or rebooting the Dwarf completely makes no difference.

This might help then Troubleshooting Windows Connection - MOD Wiki

Alternative, in the dwarf settings menu change the usb mode from “network only” to “network+midi (windows)”. Assuming you have an up-to-date Windows, this last mode creates the usb device in a different mode that is better behaved on Windows.


Wow, that was fast. And unlike last time this works perfectly :slight_smile: Awesome.

You are my

1 Like