Big USB Ground Loop, trying to set up at home

So this is pretty nasty, but I think it’s somehow because I have the dwarf in the effects loop of my amp, with the bass and amp going all through input/output/pedal chain 1, and then the amp DI out to my interface into input 1, then a midi channel into my dwarf, and using input/output/pedal chain 2 going direct from output 2 to my interface channel 2. Which works fine, until I also plug in the usb for the GUI. I’ll likely just find a different way to deal with it all, but if anyone has suggestions I’m all ears!

Oooh, Nordstrand Starlifter…

1 Like

It’s so good… I don’t really need it now that I’m back at home base, the Genz-Benz has some fantastic tone-shaping options, but I can’t bring myself to unplug the starlifter…

1 Like

I’m not sure what’s happening here. That “clank” isn’t quite the sound of a ground loop. From the moment you disconnect the USB I can’t hear that much difference regarding the hum, but that might be because you’re still moving and your chair is also making some noise.

Are you sure you’re not getting some power drain somewhere? This noise resembles when a power source is struggling to keep up with the demand, so it has periodic “drops” that cause a quick, friction type of noise.

1 Like

That “hum” that is still there when I unplug the USB is actually the fan from the side of the Genz-Benz amp. (it’s sitting sideways on a shelf so the fan is right there). I’m not sure what’s happening either, if I turn off the amp, then the output 2 (synth/mic)is clean through the interface with the USB, but as soon as I turn the bass amp on, it starts up. Any theories on what the “clank” could be?

What I can tell with high probability of certainty is that the clanking is not ground loop. That instead would be an annoying hum.

To figure out where that comes from – which is in turn needed to assess what it is – I would recommend you unplug everything then add one component at a time: Dwarf + computer, Dwarf + amp + computer, and so on. Then you can assess what the source really is.

However, this bit is telling:

which means that you might be experiencing some feedback (and the amp is closing and opening some internal gate it might have, hence the noise) or an impedance mismatch in the loop return of your amp. I would assume your GB has the typical instrument level impedance of recent years. MOD instead outputs a balanced signal.

Now the reason why it only happens when you plug USB in is really catchy. If your interface is also USB, you should be getting a clipping signal whenever the clank hits, and from the video I didn’t see that or any VU indication from the software. So it seems to be originating from the amp chain.

So my educated guess here would be that you need to rework your connection from the Mod to the amp. Perhaps use it ahead of the amp and not through the loop, see if anything changes with that.

Also, consult your GB manual and check for the loop send/return impedances and see if you have anything less than 100 Ohm at the return (highly unlikely but worth checking).

Moreover, if you’re able try this exact setup but with a laptop running on a battery (= not connected to a power outlet.)

Last but not least, can you connect the USB directly to the computer instead of using the hub? Many USB hubs do not employ isolating transformers at all.

Good luck and happy 2022.


Thanks so much for the thoughtful response!! I’ll do some testing, hopefully I can find the problem. Happy New Year!


Well, I tried shifting the Dwarf to before the amp input, and the problem persists. The noise is showing up in the VU in the interface software (the channel was muted in the earlier vid. So it’s definitely coming from the Dwarf, through the amp, and then into the DI. When I unplug the Dwarf to amp input, the noise stops, or if I unplug the USB, the noise stops. Unfortunately I can’t run this setup on battery only, as the interface plugs in (same strip as the amp/Dwarf) and also provides power to the laptop through USB-C. Maybe a bus-powered interface would work, but I would hope that the UA Apollo has some built-in protections to deal with that without causing a problem… I also tried changing from a TRS cable into the amp to an unbalanced one——— As I was typing this I think I fixed it, just realized that the DI out on the back of the amp has a ground lift switch. I hit it and the noise stopped, so it had to be some sort of ground loop… not sure where the clanking came from, or why there was a loop, considering everything in the system was going into the same Furman power strip, but as long as I can get it to work I’m happy…

1 Like

I thought I had it, but the ground lift switch only lowered the level of the noise by about 20 dB but it’s still showing up at -48 dB. I’m going to try some different cables, but I’m at a bit of a loss. I guess getting a USB hub with an isolating transformer might help— I remember reading at some point that the Mod team was going to roll out a software fix for USB cable noise as part of a system update, @jon, do you know if that’s true, or if it was part of the last release? I’m so close to getting a clean setup, but I’d love to be able to use the GUI and actively play through the Dwarf at the same time while I’m setting up my pedalboards at least. Thanks!

Update, using a Mogami XLR from the DI out into the interface instead of a Cable Matters XLR seems to have dropped the noise below -60! (comes right back up if I turn off the ground lift). I’m hoping this does it, will continue to test it out today, but at the moment I’m cautiously optimistic.

1 Like

I can’t recall anything like this. Aren’t you mistaken with the Ground Loop Compensation feature? Have you actually tried that on the setting of the MOD Dwarf?

Let us know if it does :wink:


I had the same problem using the Dwarf live. The solution was to put a ground lift plug on the Dwarf plug - problem solved. I hope this is an option and that it works for you.