File manager

Hi ,
I feel a little bit stupid…
Is there a simple way to delete several WAV or others , (together…) in the file manager…?
I didn’t found…I’ve got a hundred WAV to delete… :worried:
Thanks

1 Like

You can do it via SSH if you know linux stuff.

1 Like

Thanks, I don’t know Linux …
Is that explainable …?
I’m on osx and i can type a few words in Terminal if needed…

in a terminal you should be able to connect to SSH via

ssh 192.168.51.1

user: root
password: mod

then you should navigate to the right folder into /data/user-files

cd /data/user-files

let’s say you want remove wav files into ‘Speaker Cabinets IRs’ folder

cd "/data/user-files/Speaker Cabinets IRs"

then remove the unwanted files with rm command

rm THEFILE.wav

or remove ALL .wav files (beware! you cannot undelete)

rm *.wav
1 Like

Thanks a lot…
Do I need to install something to use SSH…?
There’s always “access denied” when I type the “mod” password…I doesn’t ask me for “user” name…Directly go to “password”…Do I miss something…?
I’m too bad…
I think I will delete manually all the files… :disappointed_relieved:
And next time , i’ll create directory before loading samples…So i can erase the folder…
One more time…Thanks for your answers.

1 Like

Try this

ssh root@192.168.51.1

then enter just mod as password

1 Like

It works this way , but i’ve done it differently , i’ve deleted all my directory ( it was SFZ samples ) and re-upload the ones i needed…
But I think it could be useful to have the possibility to select several files direct from the file manager and delete them…
Have a nice day…

4 Likes

File handing is relatively new in our system and still needs some improvements. I’m saving your suggestion on our requests list.

1 Like

Does the MOD support SFTP?

If so, in OSX, you maybe/ought to be able to use

“Finder > Go > Connect to Server” but type “ftps://user@host”

Can’t test it right now, but this might be a pretty good experience out-out-of-the-box.

Not really.
You can check all the supported formats at the moment here

It is purposefully disabled as there is no way to restrict sftp access to certain folders, thus making it too easy to mess up and ruin the file system.
You can though SSH into the unit, remount read/write and modify /etc/ssh/sshd_config (to enable sftp) and restart sshd service.

Verified to work here

This is not something we can officially support though, because as I said, it would be too easy to mess up things and ending up with unbootable unit.
So it is possible if you know what you are doing, and we won’t stop you, but then well… you are supposed to know what you are doing :wink:

3 Likes