MacBook Pro Monterey, no show

Hi, anyone tried Mod Dwarf on a MacBook Pro 2021 Monterey system.
I’m not seeing the device, it makes a connection for I see it being there in my System Preferences. But that’s it, no pop up, no connection through the Web page. It does not show up on the interface dropdown list in networks
Am I missing something? I am new on a Mac so…
Thanks and a merry Xmas

1 Like

Hi Rob,

I dont know of a pop up, I had to call the URL mentioned in the Web UI documentation page in the wiki in my browser manually. But I am still running Catalina. Dont know if that makes a difference.

Also, I experienced the connection not getting set up correctly when connecting the USB cable with the Dwarf already turned on.

It only worked after i restarted the dwarf by plugging out the power and plugging it back in, the USB Cable keeping connected meanwhile.

1 Like

What browser are you using?

As of late, some updates to Google Chrome have broken connection with the MOD (the same applies to its siblings Chromium, Brave, etc – even Microsoft’s Edge is Chromium-based!)

If you’re able try using Firefox and please report back.

There will be no pop-ups for a new connection on a Mac, but not showing in the ethernet list is telling. (Assuming you’ve been to System preferences > Network.)

Even when disconnected, the interface list on a Mac should show the Mod connection as inactive:


1 Like

It’s not workin with Firefox or either of the suggestions you made>
It’s not there in the Networklist.
What to do?

Please reach out to support and let them know about it. It might be the case that it will require some rework on Mod’s side.

1 Like

I am using my duo x on a 2020 MacBook Pro on Monterey. Prior to upgrading to Monterey from Big Sur, I couldn’t get connected using Chrome, so I started using Safari and it worked great. No troubles after updating to Monterey.


Most likely that is related with some ad-ons on your Chrome. Happy that it works fine on Safari :slight_smile:

@Jon Right. It was probably you who originally told me to try a different browser. Been happy ever since. It is the only thing I use Safari for.


Most likely :slight_smile: If yes, I’m happy that I helped you :wink: (If not, I’m happy that you solved it!)

1 Like