Max gen~ build fails


Building Max gen~ plugin fails following the instructions here:

How to reproduce

  1. Download max-gen-deploy tool at

  2. Run ./

  3. The process fails at
    File "", line 45, in <module> release_process = json.loads( File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/json/", line 338, in loads return _default_decoder.decode(s) File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/json/", line 366, in decode obj, end = self.raw_decode(s, idx=_w(s, 0).end()) File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/json/", line 384, in raw_decode raise ValueError("No JSON object could be decoded") ValueError: No JSON object could be decoded

Expected/suggested solution

The error states that it can’t decode a JSON object. So maybe the url ( at which the script looks for a JSON file is no longer available. I’m just guessing here. But I would like to hear if there’s something I could do on my end.


macOS 10.13.6

Have you heard back anything on this? I can’t seem to get either the Max Duo package or the method you are trying to work either. I am getting the same errors.

Unfortunately, I haven’t heard back. Would still like a solution to this though.

With the release of the DUO X, we had some changes in our cloud. The official Max package that can be downloaded from the Max package manager has been updated to support these changes. However, this project has not been updated to support these changes yet. We will have a look at this soon.

If you would like to do any of the advanced steps in the meantime, like changing the ttl and (or) add a GUI, the plugin can still be build with the Max package from the package manager. Once the plugin is built and deployed, it should be located on the device in the directory /root/.lv2/ . The ttl information can be adjusted by entering the device with ssh by running ssh root@ (the password is “mod”) and adjusting the information there. Alternatively the plugin can also be copied from the device to your computer by going to the terminal and using the following commands:

$ scp -r root@<plugin-name>.lv2 <local-destination-path>

Now the plugin should be copied to the location that is given at the place of the <local-destination-path> . Once it’s there the changes can be made to the bundle. When the changes are applied the plugin can be deployed to the device again by running:

$ tar cz <plugin-name>.lv2 | base64 | curl -F 'package=@-'

Thanks Bram!

Is there a way to install the Max package without using the Max package manager?
I am running Max using Wine and everything works except for the package manager -_-

Tried locally compiling using the max-gen-skeleton project, but that fails as reported here: Doesn't work with MAX 8.1.8 exports · Issue #2 · moddevices/max-gen-skeleton · GitHub

Btw, the request to results in a 308 Permanent Redirect.

At the moment there’s no way to install the Max package without using the Max package manager.
This possibility got broken and still needs to be fixed.
Sorry for the inconvenience. Keep us posted if you manage to find a workaround.

Dear Bram,
thank you very much for this information. Unfortunately the first part of the procedure work fine, but on deploying command i get an error “no plugin here” and the process quits without success.
Maybe something new appened on this thread?
Now, I’m just trying to change my max gen~ plugin to permit a parameter to be “toggled” 1 or 0 by the footswitches… Maybe there is a fast solution for allowing that?
thank you very much!

Recently we received some reports that the Max Gen deploy steps are not working. It was not yet fixed. I’m not 100% sure, but this may be the reason for your issue.

Can you please point to me which specifically?

The fix here is simple, just change the URL to https.

max-gen-deploy_v4.tar.gz from Max gen~ - MOD Wiki

Changing it to https results in:

$ ./ 
Please type your plugin name, then press enter to confirm
Submitting process...
{"authorized_by": null, "created": "2021-03-09T20:27:07.919433", "data": {"build_env": "maxgen", "build_id": 309, "builder_version": "1", "buildroot_pkg": "max-gen-plugin", "bundles": [{"mod_license": "free", "name": "testplugin.lv2", "release_number": 0, "supported_bin_compats": ["arm-a7", "aarch64-a53"]}], "developer": "MOD Devices / Cycling '74", "project": "MAX gen~ Plugins", "supported_bin_compats": ["arm-a7", "aarch64-a53"]}, "href": "", "id": "6047da1b1f75a115da604ee6", "logs_href": "", "report_href": "", "source-href": "", "status": "waiting"}
Traceback (most recent call last):
  File "", line 46, in <module>
    release_process = json.loads(
  File "/usr/lib/python2.7/json/", line 339, in loads
    return _default_decoder.decode(s)
  File "/usr/lib/python2.7/json/", line 364, in decode
    obj, end = self.raw_decode(s, idx=_w(s, 0).end())
  File "/usr/lib/python2.7/json/", line 382, in raw_decode
    raise ValueError("No JSON object could be decoded")
ValueError: No JSON object could be decoded

Alright, I know what the issue is. Give me a couple days and I’ll get this fixed.


Sure, I no longer have a max license though.
Am now looking at hvcc2lv2, probably using dpf, so then we can use puredata to create dsp graphs :slight_smile:

I tried changing the URL to https. No errors now, but the process keeps hanging at status source_verification. If I check these logs:, it says the blob doesn’t exist

1 Like

There are some current know issues with Max gen for MOD devices that we are aware of. Yet we still didn’t find time to get it fixed. Anyway, engaging here may help us pinpointing everything and get it to fix altogether. So thanks for sharing.

More on your particular issue, is this something that you get on the build?

Yes, this is happening when running the build script. And good to know you’re trying to find the time to fix these issues.

1 Like

This is working on my hvcc fork, btw -> GitHub - Wasted-Audio/hvcc: The heavy hvcc compiler for Pure Data patches. Modified to work with python3 and Distrho Plugin Format.

@DaveM there’s an issue in our cloud infrastructure (an api key expired :roll_eyes:). I’m fixing that soon and will reply here once done.

1 Like