MIDI learn 'advanced' settings not saving?


#1

Description


I’ve been trying to assign a MIDI CC pedal to vary the mix control in the FOMP delay. I want to go from 0 to 0.35. Assigning the pedal via MIDI learn is easy enough, but when I click the advanced options button, and set the range and sensitivity, it won’t save that data… The range always goes back to 0-1

How to reproduce


select MIDI learn from the actuator drop down,
move pedal
open Advanced drop down
set range to 0 - 0.35
set sensitivity to high
click save
move pedal - everything resets.

Expected/suggested solution


would love to have the range actually set the min/max for what the CC pedal (set to 0-127) will actually effect…

Additional information


  • release: 1.0.5

  • controller: 7497014

  • Operating system: Windows

  • System version: Windows 10

midi controller - KMI softstep, with connected Exp pedal, connected to the Modduo MIDI port via the MIDI expander.


#2

ranges are not implemented for midi cc addressings yet.
the ranges should automatically hide when “midi learn” is chosen though.

what browser are you using?
can you make a screenshot of your browser with this dialog open please? thanks.


#3

here’s the screen shot - in Chrome.

Would be properly brilliant if that range thing gets implemented. That and multiple functions assigned to a single Midi CC/program change are top of my wishlist, by miles :slight_smile:


#4

BTW, that’s me having set the values to where I’d want them to be, before clicking save - they go back to 0-1 range and mid level sensitivity straight away…


#5

Something’s odd then.
Those should be hidden when midi cc is selected.

Implementing ranges for midi cc is in the backlog, it will get done sometime soon.

btw, sensitivity doesn’t make sense for MIDI. MIDI always uses 127 steps.
(pitchbend being the exception)


#6

the Keith McMillen stuff has an interesting way of implementing sensitivity - especially when you’ve changed the range so it’s not 1:1 with the 127 steps of the cc command - it’s about dealing with the signal coming off an analog cc pedal, so I guess it all has to happen at the Softstep end, cos it’s already converted by the time it gets to the Mod :slight_smile:

…and I do use that pedal for pitch bend a LOT (so sensitivity is a HUGE issue, however it gets implemented) - is there an octave up effect available for the MOD yet? If not, I’ll have to do a deep-dive into how to port MAX patches over here, and get one of my MAX ninjas to write me one :slight_smile:


#7

There is a pitchshifter plugin that can pitch up (or down) 1 octave or more.
But as of right now it still consumes too much cpu to be really usable.
As soon as we’re able to optimize it nicely for ARM, we’ll push it to the store.


#8

thank you! Very much looking forward to trying it out. It’s one of the very few things my Lexicon MPX-G2 has that I use a lot that I can’t yet do in the Duo… :slight_smile:

Let me know if you need testers as you progress with it!


#9

in 1.3.0.302-RC1, the Range advanced settings don’t seem to save… i’ve tried various plugins, but the range always goes back to the default after saving. (this is on MIDI-learned CC ranges on plugins without a MIDI input)

is range on CCs only implemented for plugins with MIDI input, NOT on MIDI-learn?


#10

did it work for you with older versions ?

I am still using 1.2 (don’t know which exactly - the last stable version) and the range settings are just saved the first time I am using Midi Learn.

So if I select Midi Learn, set the range values, then save and move the fader it works. Changing them later doesn’t work (I’ve used my expression pedal with the Gain Plugin). If I wanted to change them I had to select Midi Lean once again.

This doesn’t mean that the bug doesn’t exist - it is meant as a workaround.


#11

…hmmm… ok, you’re right: this is how it works for me too! would be nice to be able to just edit the range without re-“learning”.

but, yay, it works! :slight_smile: thanks!


#12

It’s really annoying for “fine tuning” this parameter.
Hope the Mod team is going to fix this bug.


#13

This was mostly forgotten than anything else…
v1.3 features are frozen now, we added this ‘fix’ as a target for v1.4.


#14

@falkTX: sweet! :slight_smile:


#15

Great !


#16

Is this now fixed then? Thanks!


#17

Yes, this is fixed/handled in v1.4 series now.
Its changelog includes:

allow to change parameter ranges without having to re-learn a MIDI CC


#18

I see, thanks!