MIDI settings not working \ HELP!


Not able to switch midi modes inside WEBGUI. On 2 different PC, Android phone and tablet. No tick boxes. At any pedalboard.

How to reproduce

I don’t know how to reproduce, it has just appeared during banks management.

Additional information

Open the controller menu (hold left knob down), navigate to Info > Versions and write down here the version.

Unit: MOD Duo X
Build Date: 2021 Aug 25 08:47:38
OS Version:

Also provide some information about your system if possible.

  • WINDOWS 10
  • 10.0.19042 Build 19042

Have you tried loading the WebGUI with an incognito session in your browser? Does that solve your problem?
If not, try to clean your browsers cache.

I do not think this is related to browser cache, but how the browser decides to show checkboxes.
It can be a side-effect from extensions such as those that apply a dark-theme, so trying on a private session is a good idea anyway.

Weird that it happens on 2 separate PCs though.
What browser(s) are you using?

1 Like

Tested on Chrome and Opera on PC
Chrome on laptop
Opera on Tablet
Chrome on Phone

I tried to reboot multiple times, disconnect-reconnect Launchpad. Also updated to the latest firmware. Nothing works.

Also if I go to saved board with segregated mode turned on before bug - it works and I can see splitted MIDI chain, but can’t go to merged mode and vise versa.

I doubt it is about browser especially after I tried different PC and Android devices. And also connected to my usb-wifi router and accessed with wifi to WEBGUI.

I haven’t installed any extensions for really long time. It is just bam and happened. Would like add that the naming of Pedalboards again going crazy. Just randomly system renamed my few saved boards to ‘default’. Which is really gives headache to ‘save as’ and then rearrange bank againg. Glad I have not too much boards. I think maybe something with interface itself.

UPD: Today just loaded MDX as usual, with Opera browser (which I use exclusively only for MDX WEBGUI) and now these checkboxes come back. I Will test this during this day.

UPD2: I loaded my Pedalboard (on screenshot), and then switched to the default one, now this checkboxes disappeared again

UPD3: I did some tests, when im loading board from screenshot it crash this MIDI settings. If during session i switch to Default board, reboot MDX then it works again.
UPD4: This was the issue with Calf Synth, when i deleted it and saved the Board everything works fine. I know plugin in beta, but maybe this info will helps in future.


Yes, it does! Thanks for sharing it and for all the troubleshooting

1 Like

Yes, thanks a lot for the troubleshooting, this was something unexpected for sure.

I always knew calf messing up with global css rules would be causing issues one day, this shows one of them.
Plugins should always be self-contained, never modifying or creating global state.