Modsdk 500: Internal Server Error

Howdy! Taking the plunge and trying to figure out how to compile and load lv2 plugs onto my Duo. Got modsdk and plugin builder and all that installed, just hitting the wall when trying to launch localhost:9000. Looking at the errors it seems like maybe I’ve installed modsdk in the incorrect directory?

ERROR:tornado.application:Uncaught exception GET /?v=1597328433 (::1)
HTTPServerRequest(protocol='http', host='localhost:9000', method='GET', uri='/?v=1597328433', version='HTTP/1.1', remote_ip='::1', headers={'Host': 'localhost:9000', 'Connection': 'keep-alive', 'Upgrade-Insecure-Requests': '1', 'User-Agent': 'Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/84.0.4147.125 Safari/537.36', 'Accept': 'text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,image/apng,*/*;q=0.8,application/signed-exchange;v=b3;q=0.9', 'Sec-Fetch-Site': 'none', 'Sec-Fetch-Mode': 'navigate', 'Sec-Fetch-User': '?1', 'Sec-Fetch-Dest': 'document', 'Accept-Encoding': 'gzip, deflate, br', 'Accept-Language': 'en-US,en;q=0.9'})
Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/tornado/", line 1510, in _execute
    result = method(*self.path_args, **self.path_kwargs)
  File "/usr/local/lib/python3.6/dist-packages/modsdk/", line 467, in get
    with open(DEFAULT_ICON_TEMPLATE, 'r') as fd:
FileNotFoundError: [Errno 2] No such file or directory: '/usr/share/mod-sdk/html/resources/templates/pedal-default.html'
ERROR:tornado.access:500 GET /?v=1597328433 (::1) 62.25ms
WARNING:tornado.access:404 GET /favicon.ico (::1) 1.22ms

I’m using Mint and Chrome. Any help would be much appreciated, thanks!

I don’t have experience with the tool, but yeah something might be missing, in the wrong directory, and/or misconfigured. You might be able to work around this if you can find the expected file. For example if find /usr -name pedal-default.html lists the file in one or more directories. Then you could move/copy/symlink the existing mod-sdk directory so that it lives under /usr/share That would only really address this specific error message and there may be other problems further on if the mod sdk wasn’t installed correctly in the first place

1 Like

Tried that and it worked! Also had to sudo modsdk to get the server running correctly. Thanks!

Now I’m just totally stuck at the deployment phase. I click “device” and populates the device address field, then click the “Deploy via webserver” button and absolutely nothing happens. No popup message, no errors in the terminal, no plugin added to the device. Tried using both Chrome and Firefox with the same (lack of) results. And I did verify that entering brings up the Mod gui no problem. Stumped!