MODwatcher upload fails


I worked some week ago whit MAX gen~ patch to create some LV2 plugin, it was ok, really simple, it worked on the DUO.

Now it seems not to work any more: MODwatcher says “Upload failed” with all kind of patch, even with basic examples like simple_vibrato.
I’ve tried to solve the problem updating MAX, end doing a factory reset of the Duo: nothing to do… What happens? MODwatcher don’t give me any details about the failure.

Hi @Guido,

Could you send us an email to so we can open a ticket for you on our system?


1 Like

In case my experience is helpful for anybody, upload systematically fails if my DUO X is plugged through a USB hub. It works if it’s plugged directly to a computer USB port, not going through a hub first.
In older firmware versions, I was not even able to load the web interface, if the DUO X was plugged through a USB hub ; it worked only when plugged directly to a computer USB port. Now, hubs work. Maybe one day, everything will work through USB hubs ?