Reinstalling a plugin with MOD SDK

I’m trying to make a plugin and install it using the SDK. It installed correctly, but I wanted to make a few changes to it. So I uninstalled it, made the changes in the source code, recompiled it, and reinstalled it. But it re-installed the old version. Is the plugin maybe stored in cache or something, then when I re-install it it just retrieves the old one from cache?

I’m running the mod-plugin-builder in docker to compile it, and then I’m running the SDK in docker to install it. I’m running linux (lubuntu)

The plugin I’m installing is the cabsim made by @Jarno, but with different IRs. The first version I installed I put in a very long IR that takes forever to load, which is why I wanted to change it

hmm, I’m not sure what’s going on with the SDK as I’m not too familiar with it, maybe @falkTX knows whats up?

Though I push my plugins like this and never had any problems:
tar cz cabsim.lv2 | base64 | curl -F 'package=@-'

hope that helps! :slight_smile:

1 Like

That command makes it so much quicker to install plugins, thanks

Unfortunately I still get the same problem. Although I think the problem might not be what I thought it was. That command outputs:
{“installed”: [“”], “removed”: [“”], “ok”: true}builder@14b12e4fdf56

So I assume it does remove the old version and pushes the new code.

I’ll give some more details about my problem. After the plugin is installed and I drag and drop the pedal to the pedalboard, the pedal never finishes loading. It just shows the rectangular outline where the pedal would be with the loading icon in the center. But while I drag it, before I drop it, it shows the GUI of the old version. The problem persists even when I try to install the original cabsim plugin without any modifications

This is an error loading the binary.
The actual error is not yet transmitted to the browser right now, you with ssh you can debug this by trying to load it in a custom mod-host instance. like this:

echo "add 0" | mod-host -i -p 1234

This is expected, as the browser has the old version in cache.
You need to bump the version of the plugin or disable cache.

For myself, I run with the browser developer tools open and mark the setting to disable cache, very handy for development.

1 Like

BTW did you think about invalidating the cache automatically, with a hash or anything else. Cause if we use the web API to install a plugin, i don’t think it is a very big deal to do so. But that will make the plugin testing process much easier.

1 Like