[solved] High noise level at all times

Anyone getting high ambient noise in both channels?
Happens in all pedalboards and a external noise gate has to be set so high that it cuts off the start of notes.
Noise happens with or without input jacks being connected so no external source is responsible.
I may have a defective Mod Duo. How would I swap it out?

Dear drsoda,

Sorry to hear about your problem. I would like to ask you a couple of questions so we can locate the issue.

What version are you currently using? Is it a high or low pitched noise? Do you know when the problem started, maybe after an update for instance? Does it make a difference if the MOD is connected to the computer? Is it also audible when using headphones?

Best,

Bram

2 Likes

My error.
Had gain stages set wrong somehow on my setup (4 pedals before the Mod Duo & 2 after). Not sure why it got set that way

I still have noise when computer is connected to usb. I do have to dissconect usb to play live or to final check pedalboard setups.
The usb noise level is a higher pitched random noise but is low enough to allow setting up pedalboards.

Glad to hear that the other issue is solved. Now about the USB noise, that could be ground related. Do you use laptop? And if so, does the noise stop when you unplug the adaptor of your laptop?

1 Like

noise stops when usb unpluged.
Since I don’t need usb when recording/live use then unplugging is OK

Take a look at this long conversation about this issue that apparently hasn’t been resolved yet.

You can get some USB connector that isolates from the USB noise. It’s cheap.

Hi… I have The same issue… How do you solve it? Please help

I have The same issue. The noise is too much, and i have tried change input levela, output levels, cant use mod duo.
I am a kickstarter and i have already send tô mod duo to fix a hardware, but The noise still.
Can anyone help me?

I have the opposite problem. When plugged into laptop via usb the pedal is noiseless but once its unplugged i get a lot of hiss and occasional clicks/pops.
Anyone have any ideas?
Thanks in advance.

Please try the latest 1.8-RC5 build and see if it makes a difference.
There are quite a few noise related fixes in there.

Also make sure to use balanced cables on the output of the device if whatever you are plugging into (mixer?) supports it.

Thanks for the replies guys.
I’m running the latest 1.8 version, and I am talking specifically through the headphones. I have yet to try it through an amp since i noticed the noise issue.

My Duo X arrived 3 days ago. I have noticed a constant, irritating noise. Replacing the MOD power supply with an Elektron power supply (which has the same basic specs) removed the noise. The difference is quite dramatic.
(I‘d be happy to supply recordings of the noise levels if anyone is interested)
It also looks like USB connection problems disappear with the Elektron power supply.
So I have either received a faulty power supply, or the power supply supplied with the MOD Duo X is unsuitable for audio applications.

4 Likes

UPDATE: I mailed MOD Devices support about my power supply and in less than 5 minutes received a reply from Gianfranco promising to send me a replacement.

5 Likes

UPDATE: The replacement power supply arrived, but the problem persists. I have notified Gianfranco.

FINAL UPDATE: Jan from MOD Devices has spent considerable time analysing the problem and has determined that the root cause must be a ground loop in my setup. I have been able to verify that this is indeed the case. The Electron power supply only helped because it is not referenced to ground.

I am very impressed with the speed and quality of MOD Devices support and I am now a very happy customer.

7 Likes

Could we have some info on how you found out about the ground loop ? That could be super useful to other users in some circumstances.

Ideally it’d be great to have a “eliminate ground loops” wiki.

3 Likes

If the MOD Duo X sounds fine (no noise) when connected to headphones only (no output lines) or when it is the only device connected to a battery operated recorder , but is noisy when connected to other equipment, then I suppose that’s a hint that you have a ground loop.

@Azza wrote:

Could we have some info on how you found out about the ground loop ? That could be super useful to other users in some circumstances.

In my case I diagnosed a ground loop by putting a direct box (with the ground lift switch engaged) between my DuoX output and the input of my amplifier. After this change to the signal chain, the DuoX is super-quiet. For anyone with a direct box handy, this would be a test to try.

2 Likes

More thoughts: Using a direct box works great for breaking the ground loop, but isn’t so great if the downstream equipment requires a 1/4" input (for example, when going straight into a guitar amp, which is my use case). The problem is that most direct boxes have an XLR output, and getting back to a 1/4" instrument level signal is a hassle.

Inspired by @hgdaun I tried ordering an IEC Type II power supply, and this also results in very quiet operation. The power supply I’m using is a CUI SDI24-12-UD-P6 (Mouser P/N 490-SDI24-12-UD-P6). Using this power supply I can plug the DuoX directly into a guitar amp without noise problems. I don’t love the CUI power supply, though. The 12V wire seems pretty thin and vulnerable to damage. I did check its output on a scope before plugging it into the DuoX and the power seems pretty clean when it’s not driving a load.

3 Likes